I'm convinced I'm not crazy (at last)

I tried to follow the lecture until I got to the point where we do the display of collision boxes. Ever the rebel, I had used a couch instead of a chair. The couch was invisible in the collision display! On further investigation, it appears that the couch CANNOT be made to simulate physics (though it CAN be made to have a physics body).
Fearing I had done something dreadful to it (I had modified the couch); I created a new project with starter content, and tried the same thing there. Even in the new project the couch has exactly the same behaviour, so I wasn’t imagining it.

For the “simulate physics” option to be available, the static mesh needs to have an associated “simple collision”. Try this:

  • right-click the couch in the scene, and select “Edit SM_Couch”
  • “Collision” menu – “Add 10DOP-Y simplified collision”
  • Save

Now you should be able to turn on “simulate physics” on the couch.

Privacy & Terms