Ignored Library files on Global Ignore List (Mac) and can't undo it

I need some help here.

I’m using a Mac and when I ignored everything beneath “Library” I forgot to change the default settings to “This Repository Only”. So I added this entry to “Global ignore list”.

I’m not sure if this is the cause, but since then I’m unable to find the .gitignore file, even after temporarily make hidden files visible following this instructions:

  1. Open Terminal
  2. Enter defaults write com.apple.finder AppleShowAllFiles YES
  3. Relaunch Finder by right-clicking the Finder icon in the dock with the alt (option) key downfollowing the instructions on Terminal

I tried to create a new project with a different name, but even doing this I can’t see Library files anymore on SourceTree unstaged files and I can’t find .gitignore anywhere.

I’m stuck here. Could someone help me, please?

I think I solved this.

I’m not sure what happened but suddenly I was able to see .gitignore on my project folder.
(System delay?)

Now I could advance on this lesson and got my first (and second and third) commits:

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms