I somehow can't unwrap everything together. What could have gone wrong?

The unwrap simply doesn’t apply when I select everything, go to edit mode, press U and do “unwrap”, the objects keep their UVs overlapping and with huge sizes. Everything has the scale set to 1.

1 Like

I haven’t upgraded Blender to 2.8x, yet, but when I have an object with many parts loaded, I only UV unwrap each part separately. I did this when beta testing a carousel for someone, and I as I unwrapped each piece, I moved the pieces off the grid to make room for the next piece. Needless to say, I had to keep track of which group of pieces belonged to which part of the carousel.

Then when I had it all unwrapped, and double-checked that each section was not overlapping any of the others, I then “joined” all the pieces. Then when I went into the UV Editor, all of the pieces were available, and I was able to move them around so they would seem like they were done all at once.

Take note, however, you would have to grab all the pieces of the UV map at once so you can resize the WHOLE group so it all fits on the grid. This is the only way I know of getting all the pieces into one UV map, while maintaining the size of the pieces of the map.

You didn’t mention exactly what it is you’re trying to UV map, so I hope some of this helps.

1 Like

As mentioned by Miss_B, You unwrap each object individually. I do not quite see why you would even want to try to do lots or all at once. Different items might need different projections. Odds are they all want different textures too anyway.

Perhaps you miss understood something? WHEN in Edit mode of ‘one’ object, THEN ‘select all’ and U unwrap.

2 Likes

Hey people!
Sorry for the lack of info.

I’m doing the blender course in which we model an orc to learn stuff. At lesson 50, around 5:40, Grant selects all objects (except the eyes) in object mode, switches to edit mode, selects all vertices and then unwrap then, making all objects go to the same UV map, according to their scale.

I believe this is a feature that is new on Blender 2.8 (2.82? 2.83?) according to my Google searches, but I can’t be sure, since I’m 100% new to this.

Watching it again now, I believe I may just have found the issue.
It’s past my time to sleep already, however, so I’ll check again tomorrow and tell you guys what I’ve managed to do.

1 Like

I got it, guys!

The reason is: you can’t use unwrap and smart UV projection at the same time for different objects. You either smart project them all, or do a regular unwrap.

I managed to do the “unwrap them all” maneuver by manually marking the seams on all the small little items that I had used smart UV projection before, then doing their unwrap separately, then selecting all objects in object mode, tabbing into edit mode, A to select all, then U and unwrap.

There was A LOT of overlapping, but I removed (almost) them all. There are some triangles that are really really small, and I’m pretty sure it’s bad geometry on one of the small items, but maybe it doesn’t need correction.

1 Like

OK, that makes sense. I don’t usually use the smart UV projection, but even if I did, I would use that same process for everything.

1 Like

For this you can use the island option.

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.