I really need help with my Unity3D course

I’m taking the Unity 3D course and I ran into a problem on the Waypoint Circuit video of the Argon Assault Section. I followed Ben exactly and imported the standard assets pack, but when I tried to attach the waypoint script like he did, it said image

Hi Raza,

Where did you get the Standard Assets from? From the Unity Asset Store? And which exact version of Unity do you use?

I first got the assets from the asset store (I’m using 2019.3.0a7 personal) but every time I attached any script from that pack to any game object it gave me the error seen above. So instead I went to my 2017.2.5f1 version and imported the assets from the assets menu next to file and edit (in unity 2017 you don’t need to use the asset store for standard assets as they are built into the software). Then imported the waypointcircuit.cs and waypointprogresstracker.cs scripts from the 2017 project to the 2019 project. Then for some reason it worked. I don’t know why the 2017 scripts should work on 2019 but the 2019 scripts don’t work one 2019??? I’m now able to attach the scripts to gameobjects but they seem to be working differently than how they work with Ben and Rick. The movement is very fast and jerky. So I guess this problem is [half-solved]?

I’m afraid there are multiple problems:

  1. Please do not use an alpha or beta version of Unity for your actual projects. They are full of bugs. Downgrade to a stable version with an “f” in its version number.

  2. Do not import old assets if possible, download them from the Assets Store or get them via the Package Manager, which was implemented in Unity 2018.x if the relevant assets are in the Package Manager.

  3. Do not import your project into different versions of Unity. It is very likely that you break your project, and it might be that you get bugs which cannot get removed anymore. The only exception is: Your current version is buggy or you need a feature of a new version and tested the new version before you imported your project.

If possible, download the assets from the Assets Store. Maybe that fixes the problem. If not, test Tej’s solution. Do not waste too much time making your game look perfect with the Circuit asset. Rick will eventually replace it with a Timeline animation.

Thanks so much!

  1. How should I go about rolling back my project without encountering the bugs you mentioned in #3? I encountered errors when switching from 2019 to 2017, do you think I’ll be fine switching from 2019 to 2018?

  2. What’s the package manager?

PS. Thank you so much for replying so quickly! I’ve never been to a forum where my question is answered in less than a month.

  1. Try to downgrade to a stable version. For example, if you have bugs in 2019 alpha, downgrade to a stable 2019 version. Unity 2017 is already two years old. A lot of things have changed since then. Imagine it like this: If something in your computer breaks, you don’t replace it with the oldest spare part.

  2. The Package Manager was implemented in Unity 2018.3. It contains a lot of assets from the Standard Assets and a lot more, for example, TextMeshPro. If you use Unity 2018.3 or a newer version, go to Window > Package Manager.

We aim to reply within 48h hours during working days. If your problem is not too complex, it is very likely that you’ll get an answer by one of us Teaching Assistents within a few hours. If you do not get an answer within a week, it is very likely that we inadvertendly missed your thread for some reason. In this case, feel free to message us directly with a link if you still need help with your problem.

Raza Khan You are from Pakistan?

Yes. Proud to be.

My terrain was lost when downgrading…

Are you sure? Unity sometimes opens its empty default scene. Did you open yours?

It’s okay, I redid it. But its still giving me the same waypoint problem.

Did you download the Standard Assets from the Unity Asset Shop? If not, do that, please. Uninstall the old Circuit package first.

im too well Apni Discord Id batao

This topic was automatically closed after 14 days. New replies are no longer allowed.

Privacy & Terms