I have been totally stonewalled by a bug

I have been stonewalled by this bug, just do other things I guess, I will probably revert to an older version, no one on AnswerHub or UE4 Forums has any useful feedback. All necessary components are installed, all software is up to date. I cannot Create a Project. Perhaps you have an answer. the key is: " LINK : fatal error LNK1181: cannot open input file ‘ws2_32.lib’"

UE4 4.16.2 the newest version does not fix this Bug, below is the error report:

The project could not be compiled. Would you like to open it in Visual Studio?

Running C:/Program Files/Epic Games/UE_4.16/Engine/Binaries/DotNET/UnrealBuildTool.exe WorkorNoWork Development Win64 -project=“C:/Unreal Projects/WorkorNoWork/WorkorNoWork.uproject” -editorrecompile -progress -NoHotReloadFromIDE

Performing full C++ include scan (building a new target)

Creating makefile for WorkorNoWork (no existing makefile)

@progress push 5%

Parsing headers for WorkorNoWorkEditor Running UnrealHeaderTool "C:\Unreal ProjectsWorkorNoWorkWorkorNoWork.uproject" “C:\Unreal ProjectsWorkorNoWork\Intermediate\Build\Win64WorkorNoWorkEditor\DevelopmentWorkorNoWorkEditor.uhtmanifest” -LogCmds=“loginit warning, logexit warning, logdatabase error” -Unattended -WarningsAsErrors -installed

Reflection code generated for WorkorNoWorkEditor in 6.3863317 seconds @progress pop

Performing 8 actions (4 in parallel)

[2/8] Resource ModuleVersionResource.rc.inl

[3/8] Resource PCLaunch.rc





[7/8] Link UE4Editor-WorkorNoWork.dll

[8/8] Link UE4Editor-WorkorNoWork.lib

LINK : fatal error LNK1181: cannot open input file ‘ws2_32.lib’

Creating library C:\Unreal ProjectsWorkorNoWork\Intermediate\Build\Win64\UE4Editor\Development\UE4Editor-WorkorNoWork.lib and object C:\Unreal ProjectsWorkorNoWork\Intermediate\Build\Win64\UE4Editor\Development\UE4Editor-WorkorNoWork.exp

ERROR: UBT ERROR: Failed to produce item: C:\Unreal ProjectsWorkorNoWork\Binaries\Win64\UE4Editor-WorkorNoWork.dll

Total build time: 39.60 seconds (Local executor: 0.00 seconds)

Also cannot create C++ projects in UE4 4.10.4 either. Gives a different but similar error message, project will not compile.

Ok, after spending days on AnswerHub, nobody had a reliable answer, so I used the ‘reset this PC’ tool to completely reinstall a fresh copy of Windows 10, and that fixed it. I was able to create 13 projects without any compile errors, and accessing C++ files in BP projects worked perfectly. Don’t know what was wrong, perhaps never will…

Privacy & Terms