I can't package the project it says "Error Unknown Error"

MainFrameActions: Packaging (Windows (64-bit)): at AutomationTool.UE4Build.Build(BuildAgenda Agenda, Nullable1 InDeleteBuildProducts, Boolean InUpdateVersionFiles, Boolean InForceNoXGE, Boolean InUseParallelExecutor, Boolean InForceNonUnity, Boolean InForceUnity, Boolean InShowProgress, Dictionary2 PlatformEnvVars)
MainFrameActions: Packaging (Windows (64-bit)): at Project.Build(BuildCommand Command, ProjectParams Params, Int32 WorkingCL, ProjectBuildTargets TargetMask)
MainFrameActions: Packaging (Windows (64-bit)): at BuildCookRun.DoBuildCookRun(ProjectParams Params)
MainFrameActions: Packaging (Windows (64-bit)): at AutomationTool.BuildCommand.Execute()
MainFrameActions: Packaging (Windows (64-bit)): at AutomationTool.Automation.Execute(List1 CommandsToExecute, CaselessDictionary1 Commands)
MainFrameActions: Packaging (Windows (64-bit)): at AutomationTool.Automation.Process(String[] CommandLine)
MainFrameActions: Packaging (Windows (64-bit)): at AutomationTool.Program.MainProc(Object Param)
MainFrameActions: Packaging (Windows (64-bit)): at AutomationTool.InternalUtils.RunSingleInstance(Func`2 Main, Object Param)
MainFrameActions: Packaging (Windows (64-bit)): at AutomationTool.Program.Main()
MainFrameActions: Packaging (Windows (64-bit)): Program.Main: AutomationTool exiting with ExitCode=5 (5)
MainFrameActions: Packaging (Windows (64-bit)): Domain_ProcessExit
MainFrameActions: Packaging (Windows (64-bit)): copying UAT log files…
MainFrameActions: Packaging (Windows (64-bit)): BUILD FAILED
PackagingResults:Error: Error Unknown Error

This is what the Output Log shows me.

I’m getting the same error, did you figure it out @ActionMelee?

Maybe this can help?
https://answers.unrealengine.com/questions/426654/help-packagingresultserror-error-unknown-error.html

1 Like

Thanks for the suggestion, @chris.claus42! Actually, it turned out it was one of my installed plugins that was the culprit in this case. I disabled them all, and that solved the problem.

In case someone else experience the same, these are the plugins I disabled;

  • LE Extended Standard Library
  • MODO Material Importer
  • Substance Plugin

Which one (or if all of them) caused the problem, I haven’t looked into.

1 Like

I’m getting a critical error when trying to build as well:

[2016.08.26-15.29.55:500][ 0]LogOutputDevice:Error: begin: stack for UAT
[2016.08.26-15.29.55:500][ 0]LogWindows:Error: === Critical error: ===
Assertion failed: PrecacheSize > 0 [File:D:\Build++UE4+Release-4.12+Compile\Sync\Engine\Source\Runtime\CoreUObject\Private\UObject\LinkerLoad.cpp] [Line: 978]

https://www.dropbox.com/s/jwnh7af6n5pxk9c/BattleTank_Cook-2016.08.26-11.31.55.txt?dl=0 - Link to the output log.

Any help would be appreciated. I couldn’t find anything from my searches as of yet. I’ll keep looking. Thanks

I was able to fix the problem but not without careful rebuilding. I remade a new blank c++ project. I dragged the old copy onto the desktop. I remade the project in the exact same repo directory. First, I tested if it would build, and it did. Then, I moved the .git folder, gitignore and gitattributes files from the old one into the root of the new one. I built the project again, and then re-synced it with SourceTree.

Since, I have to use git-lfs for the umaps, I had to reinstall that carefully into the repo again. Essentially, when SourceTree opened up and asked if I wanted to sync my lfs files, I hit cancel. Then, I reinstalled git-lfs from the Git shell prompt (you need to navigate to the repo main directory). After I re-synced with SourceTree (essentially gutting source),
I manually added each folder (blueprints, models, materials, and levels last) by going to the old project and right clicking on the folders and selecting migrate. After each successful migrate, I would re-open the new project, and test to see if it would build. After each successful build, I would re-sync with GitHub.com via SourceTree. Everything worked in the end.

Yeah, I couldn’t find anything online about the errors. I’m guessing it’s because I moved some Blueprints around by creating additional folders and moving those BPs into those folders. You can rename BPs fine, but be careful moving them around inside your content folder. You definitely want to think ahead of time how you want to organize your project so this kind of thing doesn’t happen. Cheers

Sorry for replying sooo late I been doing collage work…I removed all plugins and it work but when I run the .exe of the game it still says it needs the plugins to run and follows up by asking if I want to download from the marketplace. I choose no to both and it runs perfect but I really want to get that out of the way. So my question is do you know how? or does this doesn’t happens to you?

BTW: I resume the Udemy class today :slight_smile: