I can't open Developer Command Prompt for VS 2019

Untitled

I have issues like that, how can i fix this ?

This appears when I click

Capture

I would suggest you try repairing your installation.

From the Windows Start Menu search for Visual Studio Installer and then the drop down menu of More for repair

It did not work…

i open the code with Developer PowerShell for VS 2019 it worked but now there is an error like this

Microsoft (R) C/C++ Optimizing Compiler Version 19.28.29336 for x86
Copyright (C) Microsoft Corporation.  All rights reserved.

triplex.cpp
Microsoft (R) Incremental Linker Version 14.28.29336.0    
Copyright (C) Microsoft Corporation.  All rights reserved.

/out:triplex.exe
triplex.obj
LINK : fatal error LNK1104: cannot open file 'kernel32.lib'

Are you sure you installed VS Community 2019 with these settings?

Settings are like this.

there is also another problem that when i write ‘cl triplex.cpp’ to cmd there is erorr like this

I have been working for these for 2 days please help.

Also i install latest verison of unreal engine(4.26.0). Could it be the problem that causing this.

You aren’t using Unreal yet so no.

If you go into Individual Components (as seen in your screenshot) do you have “Universal C Runtime” and a Windows 10 SDK installed?

All installed

I removed Visiual Studio 2019 and reinstalled. Some how it fixed but i still can not use the Developer Command Prompt directly. I open the code via VS 2019–> Tools -->Command Line --> Developer Command Prompt. Thanks for your help. Is there any solution to open developer command prompt for vs 2019 directly

The powershell version is there which you should be able to use instead. It should act the same way.

Yesterday everything was perfect. now today i got the same error AGAIN !!!

when i run the powershell as an administrator it worked. Thank you for your help. i really appreciated…