I am still having a really rough time with cavity maps

I keep putting off continuing this course because I cannot get a decent cavity map no matter what I seem to try. I’m getting artifacts all over the model. I’ve tried the following:

*Adjusting ray distance, and using 0 as ray distance as well
*Changing to CPU computer
*Using a cage (I tried copying my low poly model, scaling from the normals, but was told it couldn’t use that object as a cage)
*Adjusting the black and whites in the color ramp node on the high poly model

Here is what it looks like on my low poly model after putting the baked cavity map hooked up to the diffuse map, and the normal map is hooked up normal map.



And here is the high poly model

I’d love to hear any ideas on what I can do to improve the cavity map! :slight_smile:

I wonder if you have some messy geometry? As far as I know cavity is based on vertex concentrations and angles. Top of the head and cheeks seem to come from nowhere.

1 Like

I definitely don’t have the cleanest geometry, but I don’t think its too bad. The head doesn’t have any crazy geometry to reflect the craziness that happens after the bake.

Here are a couple pics showing the wireframe to get an idea of the topology


1 Like

Ignore me if this is incorrect, think i may have heard somewhere about using cavity maps and stuff as non color data? Its in a drop down in the node

Yes, either Linear or Non-Color data for maps which are not RGB colour maps.

You mentioned you had tried using a cage but that blender told there was an error with it.

When you scale along the normals to inflate it, make sure you do it to the whole model and not to only parts here and there.

Also you mustn’t change anything on the geo except for scaling everything at the same time along the normals (Alt+S), otherwise it won’t be able to be used as a cage.

The parts now where you’re getting black spots seem to be on areas which protrude more than others so the ray distance still doesn’t seem to far enough. Now the problem is if the ray distance is too far from the surface normals, it may start from inside another part of the mesh which means it will hit the inside of the mesh before hits the outside surface of the original surface. This is why using cage is so much better for controlling the ray distance.

The cage can intersect with itself as it is just using the surface to tell the rays where to start from and uses the face normals with the vertex ID numbers to point to the correct part of the low poly mesh (this is why cages have to have the surface normals pointing the same direction and the same vertex order). So if you scale some parts of the cage more than others then that will alter the face normals from the original low poly making it now non-identical to the low poly.

If you’re still getting black parts on the bake after you have a working cage mesh, then I would inspect the model all around and check if the black spots are visible in the high poly.

Perhaps also the black spots that remain may come from parts of the high poly mesh which intersect with itself. I doubt this is an issue here but it’s worth mentioning.

2 Likes

I’m getting the following message when I try to use the cage mesh:
image

I am following a YouTube tutorial of Grant someone posted to me in my last post, and he says to use Alt+S to scale the cage mesh to be bigger than the high poly mesh so nothing is sticking out, and I don’t touch anything else within the mesh, but I still get that error. I have no idea why it’s telling me I have the incorrect amount of faces!

Add some full screnshots and I expect it will help Mark to help you.

Logically the message suggests you have somehow changed the cage geometry from the low poly somehow.

1 Like

Yep, there’s something going wrong with it. Silly question but it’s definitely the low poly you are duplicating right to make the cage object?

If so, it could be an error with the low poly mesh, such as wrong facing normals or duplicate faces, not sure. Perhaps some screenshots might highlight the problem better

1 Like

Yes I am definitely copying the low poly model, I’ve tried it again just to make sure.

Here are some screenshots of my low poly model in edit mode:




2 Likes

Hm, perhaps I could take a look at the file? If you were able to share it somehow?

Going off the topology, I suspect there may be a few issues to address which may take along time via forum chat.

1 Like

I have uploaded my Ogre to mediafire. It was ~200mb before I compressed it to ~100mb, wow these blend files can sure get big!

Yep, the reason your Cage mesh is getting destroyed is because you need to turn off the Auto Merge vertices option. As vertices are getting close to each other, they are merging together which changes your mesh object for your cage making it different from your low poly and therefore invalid.

Once I realised you had this on, I remade the cage mesh and now it works perfectly.

I was able to bake out a nice cavity map.

Another important tip is to drop your render samples to about 8 samples. This way it bakes much faster.

3 Likes

Great find and solution Mark.
Probably never have occurred to me as I always have that off until I actually need it.

Interesting you can drop the render samples too. Presumably with no loss of quality for such a map use? If time is important to people.

1 Like

Yes, it’s just color data so not so many samples are really needed.

Maps that need more samples are usually ambient occlusion maps. I think even normal maps don’t need so many. I also prefer to use Emissive shaders and “Emit” as the bake type as this gives a true value flat value and I set my View Transform to Standard (from Filmic) and make sure the Sequencer is set to Non-Color Data or the same color space as my texture to prevent any other issues. This is all done in the Color Management

1 Like

Simply amazing! I had no idea merge vertices was on. That would make sense why the poly count was off XD . It’s working beautifully now, thank you for looking at the file and noticing that! :smiley:

2 Likes

No problem :slight_smile:

2 Likes

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.