HP Boolean behaves strange

complete-blender
17_cp_cbc
#1

Well, the boolean way to make a notch on a low poly bishop wasn’t a problem. But I tried it on a high poly bishop and it started to behave strange. Once I started to increase the subdivision, the hole disappeared and I got rather a “unity” result than a “difference”. Same when I started to increase the subdivision of the cube used to modify the bishop. Anyone similar problems? Is it something specific to the boolean modifier? Or something I am missing here?

#2

Thing is that when you have subsurf you need to maintain quads otherwise it can’t avarage the topology right.
When you are using the boolean it doesn’t take care to make the topology convert to quads thus the problems.
Maybe if you apply(not just reposition) the subsurf and then use the boolean will make it work but even then I think some stuff may end up weird

#3

True, Boolean is not good topology friendly. But this seem to be a bit different problem. As it was still there after I applied the modifier, but disappeared after I lowered the number of subdivision (after Ctrl Z to change back to the modifier applied). It seemed to appear at a certain level of subdivision - 4 for the bishop and 3 for the modifying cube.

#4

Odd.

Better make a video or take some screenshots for better understanding

1 Like
automatically bumped #5
#6

Sounds like blender is getting confused on where to cut when it has so many options to choose from.
Generally 4 is about right for a subdivide. If you start getting to 6 or 7 then you WILL start to lock up and crash blender. (I have a hexacore ryzen 5, 16gb ddr 4 and a 1060 6gb and i have managed to get to 8 subdivides but my machine went night night for 25 minutes!)

2 Likes
#7

Just as an additional thought, Did you try applying the boolean modifier first on the low poly and then add a subsurf?

automatically bumped #8