How to fix UI scaling without new theme or editing registry in GIMP 2.10.34

  1. Change your icon size in your theme settings, supported in all default themes.

  2. Change your font size in your theme’s settings file.

  • Close Gimp
  • Open the file gtkrc of your specific theme in a text editor
    • Open the Gimp themes directory:
      • Mac: /Applications/
      • Windows: C:\Program Files\GIMP 2\share\gimp\2.0\themes\
      • Ubuntu: /usr/share/gimp/2.0/themes/
    • Open the gtkrc file for your theme:
      • Light: Light/gtkrc
      • Dark: Dark/gtkrc
      • Gray: Gray/gtkrc
      • System System/gtkrc
      • other
        If you have a customized Gimp, look here for the gtkrc file
        • Mac: ~/Library/Application Support/GIMP/2.10/themes
  • Find line with: GimpDock::font-scale = 0.8333
  • Replace with: GimpDock::font-scale = 1.6666 (or another value)
  • Start Gimp again

The result (taken in 4k):

Source: macos - How to enlarge Gimp UI font and icon size for HDPI screen? - Super User

Help a sorta-newbie out? I tried a few times to open the file via the Command Prompt, but it brings up an error each time. What am I doing wrong? BTW, the CP opens with more than just C:\ in the line. You can see in the screenshot I’m including.

Ok: typing \Program Files\GIMP 2\share\gimp\2.0\themes\ is not going to do anything.

There is no executable. The last slash has to have something like gimp.exe after it. The exe part is called a file extension, and in windows it helps tell you what kind of file it is. (I mean just like linux it contains the type of file in the file header, usually, but Windows likes making things visual so it’s included in the name as well) If it’s a .jpg or a .png or a gif (among others,) it’s an image, and since Windows doesn’t open non-executables from the command prompt trying to open a file like that is fruitless. Pointless to the point of painful. If it’s a .exe or a .com or a .bat (again, among others) it’s an executable, which means you can open it by typing its name and path in the command prompt.

If you want to browse the file system, use the file browser. If you want to open a file in GIMP, run GIMP and choose open in the file menu, or use the file browser, but GIMP doesn’t set itself as the default image editor, which means you have to right click the file in the file browser and choose ‘open with’, which is hardly an elegant solution. My advice is to open gimp manually and use their file open dialogue if you want to edit an existing file.

As an additional note: usually DOS commands can have two components. the command itself, and options after the command.

Oh, and the space in “Program Files” is causing the command prompt to think your command ends after “\Program”. You need to put “” quotes around any command with a space in it. Note again that what you typed is not a command because there’s no executable and there’s no target listed after the executable.

Privacy & Terms