How to change 'Build and Run' build location


Getting two build errors in Unity, I believe it’s related to setting the build location to the same folder as the repo however I can’t find a place to change the build location. Troubleshooting the errors doesn’t help either.
First step is to change the build location and see if the errors remain.

Anyone know how to change the build location used when selecting ‘Build and Run’?

What are the errors?

Hi Bryant

Here they are:

UnityEditor.BuildPlayerWindow+BuildMethodException: 2 errors
at UnityEditor.BuildPlayerWindow+DefaultBuildMethods.BuildPlayer (UnityEditor.BuildPlayerOptions options) [0x00242] in C:\buildslave\unity\build\Editor\Mono\BuildPlayerWindowBuildMethods.cs:190
at UnityEditor.BuildPlayerWindow.CallBuildMethods (System.Boolean askForBuildLocation, UnityEditor.BuildOptions defaultBuildOptions) [0x0007f] in C:\buildslave\unity\build\Editor\Mono\BuildPlayerWindowBuildMethods.cs:95

Here are a few suggestions for you to test:

  1. Save your build on your harddrive but not inside your project folder, on your Desktop or in a cloud.
  2. Use English characters only for your file and folder names.
  3. Make sure that neither your firewall nor your antivirus program block Unity.

Hi Nina

I don’t know how to change where the build saves to. This is the main issue. I’ve read loads of documentation and watched videos and nothing shows/tells me how to do this.

I’m running 2019.2.0f1 version of Unity.

Can you provide me with steps to find where this is set?

Click on the “Build” button. Then a new window should open. Browse to, for example, D:. Create a new folder, name it Unity Builds, open that folder, create a new folder named Text 101 (or whatever you want). Open that folder. Then click on “Build” or “Save” or whatever the button in that window says.

When the build is completed, open the Windows explorer and browse to that folder. There should be an html file in it.

Hi Nina

That’s what I expected to happen but no window opens when I click build, it just builds the app again in the folder I initially selected.

That’s strange. Please try to reinstall Unity.


So I created a new project and copied the files from the one giving me hassles and I was prompted for a folder however I only get prompted once for the project.

Are you saying that every time you click build and run you’re asked to specify a folder?

That’s how it has been in my versions of Unity during the past months. Since other students are able to select a different folder, I’m pretty sure that something is wrong with your Unity installation.

Hi Nina

Ok, noted. Will reinstall.

Ok, so I reinstalled unity to the latest version and opened my project and asked it to build and run and I wasn’t prompted for a folder.

I’m going to assume that I get one chance to select the correct folder.

What happens when you click the “Build” button instead of the “Build And Run” button? No “open folder” panel either?

Do you have a firewall or an antivirus program that could be blocking Unity?

Hi Nina

On the new version of Unity there is only ‘Build and Run’ and ‘Build Settings’.

A screenshot from Unity 2019.2.3f1, a newer version than yours:

If you do not have the two buttons in the bottom right corner, update Unity.

Hi Nina

Found the ‘Build’ button in the ‘Build Settings’ window and it does open an explorer window when clicked. Problem solved. Thank you so much for your assistance.

You’re welcome. :slight_smile:

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms