How is everybody uploading a video of their games?

cud_s06_music_player_with_singleton

#1

I’ve tried with two different games now to upload a preview video and both times, it said it was too big. This last time, it was only 12 seconds so how can it be too big?


#2

Hi Penny,

Can you select the video file in Explorer and take/share a screenshot of it’s properties please.


#3

Hey Rob,

I’ve actually finished my game now but I can’t get it uploaded to the ShareMyGame site. I can’t remember what the problem was last time and how I finally got it to work. I am not getting any build errors. I just can’t get it to compress into a zip file. Every time I try, it just says “access denied.” I don’t have any special characters in the name so I don’t understand what is wrong.


#4

Hi Penny,

At what stage does this “access denied” message appear Penny?


#5

It pops up right after I right-click on my build folder and select to send to compressed folder. It will act like it is trying to do it but then that error pops up. I attached a screenshot of the error so you can see.


#6

Hi Penny,

Thanks for the additional information.

It could be that something else still has a handle on the files, e.g. they are in use somewhere, you could try to rule this out by closing any open applications, or perhaps rebooting the computer and then re-try the zipping process again.

Permissions could also be an issues, but this would really depend on how your computer is configured and probably way out side of what I could hope to provide any form of support for via the forum. You could try right-clicking and then viewing the security tab of the properties window to see that you, as a user, do have the relevant access to both those files and also the area you are trying to create the zip file in.

One thing you could try is copying (not moving) the build folder to another location, perhaps just the root of your C drive and then try the zipping process again there.

Perhaps give some of the above a try and let us know how you get on.


Updated Thu Nov 08 2018 16:09

One other thought, if you create a document in the same location, perhaps a text document or a Word document etc, and then try to zip that into a compressed file, do you get the same issue?


#7

I think it is a permissions issue because I googled the problem and found some others having similar issues. I have already tried looking at the security tab on the properties windows and making a changes to it so that it is clear that I am the owner but that didn’t work. I remember having this issue before when I tried to zip my game but I can’t remember how I fixed the problem. I think it had something to do with the temp files permission or something like that.

UPDATE: First I tried what you said about trying to zip a Word document. I got the same error. So then I went through a bunch of stuff and ended up going to my network user name and clicked the properties on it and told it to set the permissions as full there and it went through, I guess, every file on my computer so it took awhile. There were a few that it wouldn’t give me access too. Then I tried to do the zip file again and still no access. So then I tried what you said about copying the file and trying it under the root of my C drive and I still got the error but when I clicked into the folder, the zip file was there. Strange. But now when I finally got it uploaded into ShareMyGame, after it finished processing, I got an error message on it so it still did not get in there. Here is a screen shot of that error. Whew! This is turning out to be more trouble than its worth, but I hate it when I can’t figure something out.


#8

Hi Penny,

Definitely looks like the zipping up problem is PC related.

One other suggestion might be to download Winzip and give that a go, as a separate application/installation. I think I noted before that you are using Windows XP, if so you may have to do a little looking around online for an older version of Winzip as I think at the moment their minimum supported platform is Windows 7.

With regards to the error message you receive on the website, this could be an issue with the game itself, or, a corrupted zip, if you would like to upload the zip file here (if its under 10MB), or share it with me, I would be happy to have a quick look and see if there is anything I can spot. :slight_smile:

Also, if you can provide me with the URL of the uploaded game I may be able to do a little diagnosis from that also (I can see it in the screenshot, but having it as a clickable link would save me a little eye strain! :slight_smile: )

The forum will allow uploads of up to 10MB, if your project files (zipped) are larger than that you would need to use a service such as Google Drive or Dropbox, and then share the URL.


#9

Hey Rob,

I finally got it uploaded after two more tries. I had looked at the properties on the zipped folder and, for whatever reason, I didn’t have permission set on it, so I did that and tried again. It still took two tries after I did that to get it to completely upload but it finally worked. I already know there is some kind of bug with the game though because, for some reason, my fonts on the game are extremely huge and it doesn’t look that way in Unity.

Oh, by the way, I have Windows 7 – not XP.

Here is the link to my game: http://www.sharemygame.com/share/08d8ed08-0719-4ef6-bb64-62d0331e2f67

Thanks for your help.