How do you make the scripts with errors appear red in vscode?

At 2:15 vscode has the scripts that now have errors because of the change turn red. It doesn’t happen when saving the script, so I assume there’s another way. How is that done?

A few months ago, OmniSharp decided that they don’t want to support Unity “out of the box”.

Follow the instructions here, and see if this resolves your problem.

I unticked the option, it didn’t fix the issue. To clarify, if I click on a script with an error it becomes red, but I can’t see it before then.

Hmmm… I’m not entirely sure why… a few things to try:

  • Make sure your VS Code plugin is up to date.
  • In Unity, go to Editor|Preferences|External Tools and Regenerate Project Files.
  • Close Unity and VS Code. Navigate to your project folder and delete the Library folder.
  • In VS Code: TOOLS → Options… → Text Editor → C# → Advanced → Underline Errorsl in the editor
  • in Vs Code: Tools → Import/Export Setttings → Reset all settings.