How can i refactor this code?

Hello guys this is my current code. I am uncomfortable with the current situation because when I add new types of rewards I need to modify the switch case every time. How can I lose the switch statement and make it easier to add new types of rewards?

Privacy & Terms