How can i fix this jagged look on my model

this also happened to my bishop but when i appended it to the chess scene it stopped looking like that i haven’t tried appending this one yet
i would appricaite help and thanks in advance <3 .

Very hard to tell from this. It may just be graphics card issue.

Checking the usual suspect though would be face normals all looking outwards. Checking for no duplicate geometry. Rule those out first. others may then have more ideas.

1 Like

i tried merging by distance and nothing was removed so no dublicate geometry ,and when i checked the normals it was weird the color varied whenever i zoomed in and out as shown in the screenshots and i tried to recalculating them using shift N nothing happened.
also fliping them will turn them 100% red .
i have an amd rx580 8 gb and 8gb ram i don’t know how good it works for blender.
also big thanks for taking the time out to reply to me i appreciate it <3.

1 Like

Looks very like extra geometry to me. Are you selecting all, A, before merging by distance?
Another way you can find that is selecting a vert and moving it about, it may reveal another right under it. Ctrl z to undo moving. If there is something extra there you can do merge by distance and use the popped up panel to increase the distance it will merge away.

tried A merge by distance but didn’t remove any vertices and if i increase the distance the shapes gets altered in a funky way
it might be the graphic card i’ll try appending the model to the chess scene when i did that with bishop model the jagged edges disappeared.
thanks for the help and if u find something out please let me know .

Complete Blue is good.

But your normal lines are on the vertices. Which is an option, but it’s better to have them on the centre of the face. Do not try all options to see what’s happening. if you don’t understand them well, keep off from it. Because I see things, which are not normal Blender configurations at the start. Lot’s of people are tweaking Blender in the beginning, because they can. But they have no clue why they need it. Keep blender original. It helps you also to understand this lesson better. Because they are based on Blender defaults.

I see a red line, meaning you have Marked seems, which are not needed in these lessons.

Did you apply the scale. ?

thank you very much for the tip
that was the only thing that i altered that wasn’t mentioned in the lectures
also i didn’t need to alter the scale of the model at all because it was a bishop model that i edited in edit mode so all scalings and movings were done in edit mode .
i tried applying all transforms but nothing seemed to change.

upload your file if you wish?


thank you for helping

Maybe you could do this: (I am using a sphere just for simplicity)

I checked out your file and it looks like the problem is that your geometry is litterally too close together. I was able to fix the weirdness by using loopslide to move the edge ring forming the lowest point away from the outer geometry.

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.