"Hot pixels" when using Cycles render engine

Hello!

I’m having a strange effect on my well, rendering it with the Cycles engine: I’ve got some “hot pixels”, like fairies on my screen. Even if I do appreciate that Blender puts some magic inside my images :stuck_out_tongue: I’d like to know why this is happening.

Thanks :slight_smile:

Well.blend (1.8 MB)

The Fireflies you are seeing are caused by the way your light is interacting with the material you’ve made and the camera. There are a couple of ways to fix this including enableing the De-Noise option, reducing the amount of light or sometimes moving the light source a bit, or upping the render samples.

Thanks @Capricas_Kirito for the reply. My question is thus another: how is that following the lecture step-by-step, the result in the video recording doesn’t match mine? I mean, my material is just the standard one with a color applied (as far as I learnt), but I don’t see the fireflies effect in the lesson’s render. Thanks :slight_smile:

It could be a simple matter of the compression that is applied to the video or a difference in the software itself or even in the difference in the machines we use to run the program. For instance, I could barely see anything in your render but when I downloaded the file and opened it, the fireflies were as prominent as the full moon in a cloudless sky.

I know that’s not a very satisfying answer and maybe @irresistiblejelly or @Michael_Bridges could give something a bit more detailed but the biggest lesson I’ve learned from Michael’s courses is that – often, following the exact steps in the video doesn’t solidify the knowledge the way really making the project my own does. Of course, as a Kinesthetic Learner, I get so much more from the challenges than from watching or listening to the videos that I’m not even sure how to express the difference without insulting one of the better instructors I’ve come across. So, don’t be afraid to go out on a limb to explore things on your own.

9/10 times its scale, Light is relative to the scale of your scene so if your well is 10 times the size of the model in the course (Which can and does happen easily) then the lights need to be adjusted accordingly.

I havent got access to a computer atm (using a phone to check in as away today), so i am unable to check the file to see if that is the issue here.

Its likely though that this is the case and we will cover this in more detail in later section and also the importance of it especially when using the depth of field options to focus on a specific object.

You can try scaling your entire scene (models not lights and camera and this is where collections are helpful by right click you can select only the collection).

Let me know if this helps at all and i will try to take a look tomorrow when i am back at my machine

Hello @irresistiblejelly,

Thanks for replying. I’ve tried playing with the settings and it seems it has something to do with the path tracing bounces: turning them from (total) 12 to 0, the problem is not present (even if the light seems to be of a non-atmospheric planet, of course, with sharp lights and shadows). If I set them even to 1, the problem appears again. I’ve tried playing with clamping of indirect light, setting it even up to 1,000,000 with no results. I’m going to scale the model now to try if that can resolve the issue.

Thanks :slight_smile:

And here we are.

I’ve scaled the models up, but I noticed the same noise of the starship I published earlier. I’ve then increased the sampling from 128 to 1000 and the noise reduced, even if not completely. I’m sure I’ll learn more about cycles during the course :slight_smile:

1 Like

Managed to take a look in the space of 5 minutes i got a break lol
Go to all your lamps and press use nodes and then turn up the values to somewhere in the region of 2000-3000

That should see a lot of improvement there and also the denoising mentioned when you render.

If you are using your GPU you might also like to find the performance tab and change to 256 * 256 as it tends to be faster for higher end gpu’s

Let me know if you have any issues

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.