[Help]When I Build and Run the game it doesnt't work

Hi I’m at the lesson 48 Number Wizard game .The game works and when I click the buttons it loads other scenes,but when I did Build and Run it doesnt’t work and I can’t click the buttons

Hi @Alfonso_D_addio, are all of the scenes added within the Build screen?

Hi @Rob all the scenes are added but when i run the game I can’t click any button ,it’s like blocked

Strange behaviour indeed. I was about to suggest whether perhaps there was a layering issue, e.g. the buttons are behind something else, but then you have said that it works when you run it locally.

I would be more than happy to take a look at it if you are able to zip it all up and upload it somewhere for me to grab?

I had a similar issue, and it was really weird.

What I did to fix it was rebuild it, use the same name, and overwrite, and when you launch, launch in “Windowed Mode”. I don’t really know what difference it makes, or if that is what actually helped me, but it was what I did, and then it worked.

Hope it helps!