[Help] Unity is unable to run compiler

I’m receiving a pair of error messages when I create a script in Unity. Here is a screenshot showing the error message that actually has anything that can be used to troubleshoot it.

Observed Behavior
The Unity console spits out a pair of error messages, one of which is empty of everything except “Compilation failed because the compiler couldn’t be executed!” and the other of which you can see in the screenshot.

Expeted Behavior
Unity doesn’t print anything to the console when a script is created.

Steps to replicate
This ties into the problem with steps tried, I don’t know exactly what is causing this problem. I tried removing a seperately downloaded copy of MonoDevelop (different from the one included with Unity), to see if the computer was getting confused by it, but that did not resolve the problem.

Relevant Info
Unity version 4.7.2f1
MonoDevelop version 4.0.1

Attempts to resolve problem

  1. Removed independently downloaded copy of MonoDevelop.

Has this ever worked, or has it always had this problem?

If it’s never worked, I can’t say for sure, but I try to avoid special characters such as apostrophes in file paths (E:\ Caleb’s Data). It’s probably not that though.

Mono and MonoDevelop are different things - Mono is the opensource dotnet sdk, MonoDevelop is the IDE. It looks like your problem is Mono, which is something I’d probably reinstall Unity for if a reboot didn’t fix it.

Also, try Visual Studio Code or Rider rather than MonoDevelop.

1 Like

Privacy & Terms