[Help] Really dumb question Re: dragging images

Hi,
I have dragged my background image to the Scene panel and it is not showing up even when I double click or zoom on it. It appears in the hierarchy though. I am having the same issue with the ball image. I have tried quitting/reopening Unity and deleting the image then re-inserting and only dragging into hierarchy pane, and double checking that the image file was in the correct location. Screenshot included shows what my screen looks like when double clicked on the background image.

What’s the Z position of your camera?

my z position is -10

Make sure the Pixel per unit of the BKG image is correct, Ben used 50 (you can check this by selecting the sprite in the Asset>Sprites folder and change it in the Inspector (right hand window)
Make sure the camera size is correct, again Ben uses 6 here,
Make sure the BKG and MainCamera transforms are correct, i noticed your BKG image is at co-ordinates or approx x=349 y=348, if you screen space is very small, then your BKG image would be way off, again BEN 's is at x=8 y=6 because the screen space is 16x12, putting both the camera and the BKG image in the middles of the screen space. If you do thats and for some reason you only see a corner of you background image then check the pivot point,

other that that, id try re-do the chapter and making sure you match all the figures perfectly using Ben’s assets

Hi, I have checked all of your suggestions and double checked to make sure my measurements match that of Ben’s. I am now able to see the background image in the games tab only not the scenes tab but not the ball at all. I have imported the ball into a new project and it is visible under the games tab. I went back to blockbreaker and tried importing it again and I have also tried relayering the objects in the hierarchy pane but ball is still not visible. I am using unity version 5.3.5f1 - are all sprites supposed to be visible from the scenes tab? The screenshot is what the scenes tab looks like when I double click on the ball

i

i’m sorry but if all your setting match Ben’s there I’d have to assume the reason is either your version of Unity (I’m using the suggested version Unity 4.6.9f1) or maybe a setting is wrong somewhere:

just below your scene/game tabs there’s a box with Shaded, check if there’s a textured option?
the only other thing i can think of is checking the actual Alpha of the ball sprite, in sprite renderer go to the color box and make sure the A slider is at 100%.

theres nothing else i can think of sorry, hopefully if that doesnt help someone else will find the solution, might be better just starting the whole tutorial again from scratch in case you missed a vital setting that has thrown everything else off,

good luck

Hi @Nechama_R, can this topic be marked as [Solved] now?

If it was not solved, perhaps the problem is that the background and ball seems to be at the same Z position, try moving the ball to a z position between the camera and the background