Help Needed with Freestyle Line Rendering Issue

Hello everyone,

I’ve been encountering an issue with Freestyle rendering in my Blender project and after several troubleshooting attempts, I’m turning to the community for help.

In my scene, which consists of various coral-like structures, I’m attempting to use Freestyle to add stylized lines to the render. However, the lines are only partially rendering, mostly appearing around the borders of some objects, and not throughout the entire scene as expected.

I’ve confirmed that my edge types (Silhouette, Border, Crease, Edge Mark, Contour, External Contour, Material Boundary, Suggestive Contour, Ridge & Valley) are all selected with the Logical OR combination setting enabled.
The “Culling” option is checked, with a Crease Angle of 134°.
I’ve attempted to adjust various Freestyle settings such as Face Smoothness, Sphere Radius, and edge detection thresholds to no avail.
I’ve checked that the Freestyle Line Set is indeed enabled for all objects and that visibility settings should not be causing the issue.
I have also tried simplifying the scene to reduce complexity, which did not solve the problem.
All textures are properly loaded, and there do not appear to be any missing data or errors that could explain the issue.

Could anyone suggest what might be preventing Freestyle from rendering lines across the entire scene? Are there known issues with Freestyle in certain contexts or with specific types of geometry? Any insights or suggestions for further troubleshooting steps would be greatly appreciated.

I am attaching several images of the render output and the Freestyle settings for reference.

Thank you in advance for your time and help!

Interesting. Freestyle is not something I’m familiar with, but after getting nowhere with this amount of permutation testing in your settings, I would suggest trying to gather more data.

  • Have you used Freestyle successfully before? I imagine the answer is yes, but it’s worth asking to eliminate any sort of configuration or incompatibility issue.
  • Do you have any past projects that you could easily apply Freestyle to (“apply” is maybe the wrong word, but I’m sure you can see what I mean), and do those work as expected?
  • If you add more meshes/Objects to the problem scene, are you able to make Freestyle influence them consistently? Similarly, are you able to Append things from [other scenes where Freestyle worked correctly] into this one and make Freestyle influence those as well?

Hopefully these additional tests give you a thread to pull on, as this is as much as I can offer.

Freestyle does have a small list of known limitations; it doesn’t seem like anything that would affect your situation, but you would know more about that than I would: Introduction - Blender 4.1 Manual

Best of luck =)

1 Like

Appreciate the suggestions. Freestyle has been part of my workflow, primarily through render passes and compositing. I suspect the compositing might be contributing to the issue, but I’m not certain how to isolate the problem. I’ll explore the points you’ve raised and see if they shed any light.

Thanks again.

1 Like

Isn’t it so, the FreeStyle is part of Greas Pencil Art!
Where you can use 3D obects inside the Grease Pencil (2D/3D) render environment?

Trying to say: Are you using Grease Pencil, or a feature of Grease pencil in the 3D world?

Thanks for the response @FedPete.

No Grease Pencil involvement here, just straight-up Freestyle in the 3D render. Here’s the compositing setup:

I’ve been tweaking Freestyle settings, but it’s only affecting a portion of the scene. If you have any thoughts on why this might be happening, I’d appreciate your insight. :woozy_face:

1 Like

I thought that this option only works well in Grease Pencil mode.
Because in Grease Pencil mode it will create a 2D layer with those lines.
This layer sits inbetween the object scene and camera.
If you move away from this viewpoint, those line wills shift away from the objects.
It have no relation with objects itself.

Maybe examine the docs about this subject

I’ve lost my project about this matter.

  • May normals inverted?
  • Or like viewport and camera, some clipping is involved?

Hey @FedPete,

I appreciate you jumping in with your insights. To clarify, I’ve been using Freestyle strictly for rendering stylized lines in 3D, not within the Grease Pencil environment. Despite my efforts to adjust Freestyle settings and even splitting the scene into separate view layers for better memory management, the issue persists—only parts of the scene are outlined, leaving me in a bit of a bind.

Your point about the possibility of issues like inverted normals or clipping that could be impacting the Freestyle render is a good one. I’ve double-checked these, and everything seems to be in order, yet the lines still don’t render fully across the scene. It feels like I’m missing a crucial step somewhere.

Since you mentioned the docs, I’ve taken another look to ensure I’m not overlooking any limitations or specific settings. Still, it’s puzzling that I’m encountering this problem when previous projects with similar complexity rendered just fine.

Could there be a bug with the current Blender version I’m using (4.1), or might it be related to specific geometry settings within my scene? Any further thoughts or troubleshooting tips would be a great help.

Thanks for bearing with me!

1 Like

Actually, there is a chance that has something to do with it. Unlikely to be a bug, but upgrading to 4.1 might have changed the workflow slightly, which could very easily introduce that “crucial step you’re missing.” Either way, that’s another dimension to investigate via divide-and-conquer testing like the other stuff; since everything worked fine before, it’s worth looking into.

Also, it seems to me that only Objects on the left side are being rendered, as if Freestyle can only see half of your scene (though this is almost certainly more an issue of cutoff than visibility, as you alluded to earlier). That would fit with your hypothesis about the compositing setup excluding things that it shouldn’t, but why specifically the left side? I would try taking some of the Objects that are working correctly and moving them to the right side temporarily; regardless of whether that still works or not, it will rule something out.

If your tests suggest that compositing is where you need to look, then I would apply the same type of testing to your compositing tree, but of course back up your scene first. I know very little about Blender’s various node systems, but the general approach to this sort of troubleshooting is to incrementally remove restrictions (like value clamps, and culling for that matter) and/or add more inclusive things as necessary until either the a-ha moment comes, or you’ve made your detection scope as inclusive as possible and the issue persists (in which case compositing could still be the problem, but you would now know that it’s not the entire problem).

Thanks for reading my text walls! XD


I guess this screenshot should rule out these am I wrong? I mean I’ve checked the cam and it’s 50mm Perspective which is by default I assume? and reduced the memory to 351MB but still it does partially render this scene :confused:

1 Like

I wanted to update you on the issue I was experiencing with Freestyle rendering in Blender 4.1. After much investigation and your helpful insights, I finally had my

The problem stemmed from an animation layer that I didn’t realize was interfering with the Freestyle pass. I originally created a caustics animation for the scene, and it seems that I accidentally included it when setting up the view layers for the Freestyle render. Once I removed this pre-existing animation from the base_scene, everything started to render correctly.

Thank you all for your patience and support for guiding me through the troubleshooting process. Your advice was invaluable, and it’s always great to know you have a community to turn to when things get tricky. :partying_face:


Brilliant! Congratulations =D


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms