Having trouble creating the Moving_Platform actor

I followed the tutorial. I did have Visual Studio 2022 installed already as well as the VS code, I had to add the
unreal engine plugin that was showed. I was not able to add the actor and trying to do so made it so when i tried to open the project again I was not able to. Not wanting to do the tutorial up to this point again I tried adding the actor to a blank project and got the same results. I will attach screenshots, thank you for your time.


I don’t know if this will help solve my problem but in the folder source file it shows this. Thank you for any help.


I think I may have fixed the problem by downloading the newest microsoft dotnet core framework version 3.1.3. I have no idea what version I had or even what exactly that is, to be completely honest but it seems to have fixed it.

There was a bug in UE5 that caused issues with building. It was fixed in a newer VS 2022 update and also a newer UE5 update (I think 5.0.2 addressed it, possibly 5.0.1) but this also was dependent on the correct .net core 3 being installed.

I hope you’re up and running now.

Yes, got it up and running, almost done with the tutorial. I’m really liking this site, thank you.

I have had the same problem just now (I’m using UE 5.1). Turned out the .net version I installed wasn’t the right one.
A quick way to find out which one you need is to try to create a new c++ game. I got an error saying that I did not have the required .net version installed. It also gave me a link to the download of the required package.
After downloading that version (6.0.11) everything worked fine for me.

Hope I could be of help

1 Like

Where do you go to get the correct .Net version? Nevermind, I found where to get it. I checked and I have the latest version of DotNet.Core app Net Framework 4.8. So, that must be too new? I am getting the same error message:

Here is the Output Log section that may be helpful:

You must install or update .NET to run this application.
App: C:\Program Files\Epic Games\UE_5.0\Engine\Binaries\DotNET\UnrealBuildTool\UnrealBuildTool.exe
Architecture: x64
Framework: ‘Microsoft.NETCore.App’, version ‘3.1.0’ (x64)
.NET location: C:\Program Files\dotnet
The following frameworks were found:
6.0.14 at [C:\Program Files\dotnet\shared\Microsoft.NETCore.App]
7.0.3 at [C:\Program Files\dotnet\shared\Microsoft.NETCore.App]
Learn about framework resolution:

I need help.

There is more to my problem than just the dotnet. I did find Microsoft.NETCore.App and installed version ‘3.1.0’. However, I still get the error message shown in this topic. I also get alerts from my virus protection. It does not like code being run on my machine. I don’t know how to fix that.

You need to have .NET core v6 installed on your PC. As for running your code on your PC, you may need to add a folder exception. Is this your own personal PC?

You may need to set your working folder to be ignored. Make sure this folder is not in your documents or in any folder used by the likes of OneDrive but rather create a folder on your drive called development i.e. c:\development and then create your projects in there. This should help but it may not solve your problems.

Yes, it is my own personal pc. I just got this new pc with a nice graphics card (RTX 3080) running on Windows 11. My AntiVirus is blocking all the C++ code I try to write and I don’t understand what needs to be done. This is all getting to be very frustrating. I skipped ahead to the next lecture section on CryptRaider and as soon as I reached a lecture on using C++, I get the same virus protection blocking my work in C++.

BTW I thought I got the latest version of .NET core but how do I know if it is v6 or not?

Here is the latest failed code writing message:

Running C:\Program Files\Epic Games\UE_5.0\Engine\Binaries\DotNET\UnrealBuildTool\UnrealBuildTool.exe -Target=“CryptRaiderEditor Win64 Development -Project=”“D:/My Unreal Projects/CryptRaider/CryptRaider/CryptRaider.uproject”"" -LiveCoding -LiveCodingModules=“C:/Program Files/Epic Games/UE_5.0/Engine/Intermediate/LiveCodingModules.txt” -LiveCodingManifest=“C:/Program Files/Epic Games/UE_5.0/Engine/Intermediate/LiveCoding.json” -WaitMutex
Log file: C:\Users\richr\AppData\Local\UnrealBuildTool\Log.txt
Target is up to date
Total execution time: 0.38 seconds
File D:\My Unreal Projects\CryptRaider\CryptRaider\Intermediate\Build\Win64\UnrealEditor\Development\CryptRaider\CryptRaider.cpp.obj was modified or is new
File D:\My Unreal Projects\CryptRaider\CryptRaider\Intermediate\Build\Win64\UnrealEditor\Development\CryptRaider\CryptRaiderCharacter.cpp.obj was modified or is new
File D:\My Unreal Projects\CryptRaider\CryptRaider\Intermediate\Build\Win64\UnrealEditor\Development\CryptRaider\CryptRaiderGameMode.cpp.obj was modified or is new
File D:\My Unreal Projects\CryptRaider\CryptRaider\Intermediate\Build\Win64\UnrealEditor\Development\CryptRaider\CryptRaiderProjectile.cpp.obj was modified or is new
File D:\My Unreal Projects\CryptRaider\CryptRaider\Intermediate\Build\Win64\UnrealEditor\Development\CryptRaider\Mover.cpp.obj was modified or is new
File D:\My Unreal Projects\CryptRaider\CryptRaider\Intermediate\Build\Win64\UnrealEditor\Development\CryptRaider\TP_PickUpComponent.cpp.obj was modified or is new
File D:\My Unreal Projects\CryptRaider\CryptRaider\Intermediate\Build\Win64\UnrealEditor\Development\CryptRaider\TP_WeaponComponent.cpp.obj was modified or is new
File D:\My Unreal Projects\CryptRaider\CryptRaider\Intermediate\Build\Win64\UnrealEditor\Development\CryptRaider\CryptRaider.init.gen.cpp.obj was modified or is new
File D:\My Unreal Projects\CryptRaider\CryptRaider\Intermediate\Build\Win64\UnrealEditor\Development\CryptRaider\CryptRaiderCharacter.gen.cpp.obj was modified or is new
File D:\My Unreal Projects\CryptRaider\CryptRaider\Intermediate\Build\Win64\UnrealEditor\Development\CryptRaider\CryptRaiderGameMode.gen.cpp.obj was modified or is new
File D:\My Unreal Projects\CryptRaider\CryptRaider\Intermediate\Build\Win64\UnrealEditor\Development\CryptRaider\CryptRaiderProjectile.gen.cpp.obj was modified or is new
File D:\My Unreal Projects\CryptRaider\CryptRaider\Intermediate\Build\Win64\UnrealEditor\Development\CryptRaider\Mover.gen.cpp.obj was modified or is new
File D:\My Unreal Projects\CryptRaider\CryptRaider\Intermediate\Build\Win64\UnrealEditor\Development\CryptRaider\TP_PickUpComponent.gen.cpp.obj was modified or is new
File D:\My Unreal Projects\CryptRaider\CryptRaider\Intermediate\Build\Win64\UnrealEditor\Development\CryptRaider\TP_WeaponComponent.gen.cpp.obj was modified or is new
Building patch from 14 file(s) for Live coding module D:\My Unreal Projects\CryptRaider\CryptRaider\Binaries\Win64\UnrealEditor-CryptRaider.dll
Creating library D:\My Unreal Projects\CryptRaider\CryptRaider\Binaries\Win64\UnrealEditor-CryptRaider.patch_3.lib and object D:\My Unreal Projects\CryptRaider\CryptRaider\Binaries\Win64\UnrealEditor-CryptRaider.patch_3.exp
Successfully linked patch (0.000s)
Cannot open file D:\My Unreal Projects\CryptRaider\CryptRaider\Binaries\Win64\UnrealEditor-CryptRaider.patch_3.exe. Error: 0x5
Cannot load patch executable D:\My Unreal Projects\CryptRaider\CryptRaider\Binaries\Win64\UnrealEditor-CryptRaider.patch_3.exe
---------- Finished (0.000s) ----------

Ok. The logs are saying ue5.0 and this means you need dotnet core 3.1

I thought I installed dotnet core 3.1 last week. I will check.

from the command-line, you can enter this command:
dotnet --list-sdks

This is what I get when I run the command:

3.1.426 [C:\Program Files\dotnet\sdk]
7.0.201 [C:\Program Files\dotnet\sdk]

So, I think I am up to date though I don’t know what dotnet is or its function.

I really think my problem stems from my Antivirus software is blocking me from coding on my computer. Everytime I run some code that is part of my project that I am getting from the lectures, my Antivirus Program puts a pop-up on my screen that says it is blocking a threat. If I temporarily suspend my Antivirus program and do it again, the coding runs properly without a problem. I don’t know how to tell my Antivirus program to let me run code and compile code on my own computer. I am sure it has something to do with exceptions but I have never been successful telling the Antivirus program about exceptions.

Privacy & Terms