Having problems with unreal and visual studio!

Hi there,

I’ve run into a bit of a problem. When I first got my computer a few years ago, I installed visual studio 2013 express (forgot that I downloaded express instead of community smh). Since then I have installed 2015 community and 2017 community (I downloaded this one for the course). At the first part where we write the PositionReport, I noticed that Unreal automatically opened up visual studio 2013 express (for which the trial ran out like 3 years ago). I figured that I would uninstall 2013 express and that 2015 and 2017 community would be fine, but now I am getting an error message from unreal when I try to open the code that I must have 2012, 2013, or 2015 installed. What should I do? is there a way to set 2015 as the default or 2017?



Hello Miles,

Unity provides an external script editor setting that you can change to be any editor you have installed. Here is a post on Unity Answers that should help you set it up.

From the comments on that post, the location of the executable for Visual Studio 2017 should be similar to the following.

C:\Program Files (x86)\Microsoft Visual Studio\2017\Enterprise\Common7\IDE\dev.exe

I hope this helps.

Happy Coding :slight_smile:

What do you have set in your Unreal Editor Settings.


See what you have set in there. If that is no good try reinstalling Visual Studio 2017.

Do you really want to keep VS 2015 too?


Hi, It worked when I reinstalled visual studios! I’m not exactly sure what
happened though. Thanks for the responses!


Privacy & Terms