Having Massive issues compiling code

I have spent the last 4 days trying to compile this code from Episode 42 of Unreal Engine 5 course. I have run into so many issues and I keep getting the same error code. I will past the error code Below. followed by what I have done so far to try and fix the problem.


Executing task in folder ObstacleAssault: Engine\Build\BatchFiles\Build.bat ObstacleAssaultEditor Win64 Development ‘C:\Users\kmmf8\Documents\Unreal Projects\ObstacleAssault\ObstacleAssault.uproject’ -waitmutex

Running UnrealBuildTool: dotnet “…\Engine\Binaries\DotNET\UnrealBuildTool\UnrealBuildTool.dll” ObstacleAssaultEditor Win64 Development “C:\Users\kmmf8\Documents\Unreal Projects\ObstacleAssault\ObstacleAssault.uproject” -waitmutex
Log file: C:\Users\kmmf8\AppData\Local\UnrealBuildTool\Log.txt
Building ObstacleAssaultEditor…
Using Visual Studio 2019 14.29.30147 toolchain (C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\VC\Tools\MSVC\14.29.30133) and Windows 10.0.19041.0 SDK (C:\Program Files (x86)\Windows Kits\10).
[Upgrade] Using backward-compatible include order. The latest version of UE has changed the order of includes, which may require code changes. The current setting is:
[Upgrade] IncludeOrderVersion = EngineIncludeOrderVersion.Unreal5_0
[Upgrade] Suppress this message by setting ‘IncludeOrderVersion = EngineIncludeOrderVersion.Unreal5_1;’ in ObstacleAssaultEditor.Target.cs.
[Upgrade] Alternatively you can set this to ‘EngineIncludeOrderVersion.Latest’ to always use the latest include order. This will potentially cause compile errors when integrating new versions of the engine.
Determining max actions to execute in parallel (8 physical cores, 16 logical cores)
Executing up to 8 processes, one per physical core
Requested 1.5 GB free memory per action, 1.3 GB available: limiting max parallel actions to 1
Building 4 actions with 1 process…
ERROR: System.ComponentModel.Win32Exception (998): Invalid access to memory location.
at EpicGames.Core.ManagedProcessGroup.get_TotalProcessorTime() in D:\build++UE5\Sync\Engine\Saved\CsTools\Engine\Source\Programs\Shared\EpicGames.Core\ManagedProcess.cs:line 165
at EpicGames.Core.ManagedProcess.get_TotalProcessorTime() in D:\build++UE5\Sync\Engine\Saved\CsTools\Engine\Source\Programs\Shared\EpicGames.Core\ManagedProcess.cs:line 1207
at UnrealBuildTool.ParallelExecutor.RunAction(LinkedAction Action, ManagedProcessGroup ProcessGroup, CancellationToken CancellationToken) in D:\build++UE5\Sync\Engine\Saved\CsTools\Engine\Source\Programs\UnrealBuildTool\Executors\ParallelExecutor.cs:line 301
at UnrealBuildTool.ParallelExecutor.ExecuteAction(Task`1 AntecedentTasks, LinkedAction Action, ManagedProcessGroup ProcessGroup, SemaphoreSlim MaxProcessSemaphore, CancellationToken CancellationToken) in D:\build++UE5\Sync\Engine\Saved\CsTools\Engine\Source\Programs\UnrealBuildTool\Executors\ParallelExecutor.cs:line 268
[1/4] Link UnrealEditor-ObstacleAssault.lib cancelled
[2/4] Link UnrealEditor-ObstacleAssault.dll cancelled
[3/4] WriteMetadata ObstacleAssaultEditor.target cancelled
[4/4] Compile MovingPlatform.cpp cancelled

  • The terminal process “C:\WINDOWS\System32\WindowsPowerShell\v1.0\powershell.exe -Command Engine\Build\BatchFiles\Build.bat ObstacleAssaultEditor Win64 Development ‘C:\Users\kmmf8\Documents\Unreal Projects\ObstacleAssault\ObstacleAssault.uproject’ -waitmutex” terminated with exit code: 1.
  • Terminal will be reused by tasks, press any key to close it.

I have tried quite a few things and all have failed.

  1. I have attempted restarting the project from the beginning,

2.used revo to uninstall all programs and then reinstalled them. making sure each one is correct.

3.Reset my entire PC and then Tried the project again from the beginning.

A myriad of things online such ad disabling command prompt 2.0 and running different commands as admin. I have tried earlier versions of Unreal and different versions of VSCode.

I have hit a brick wall and I am getting very frustrated at this point. The only clue I probably have to go on is ERROR: System.ComponentModel.Win32Exception (998): Invalid access to memory location.

Live Coding fails every time. Sometimes at complete random the VS code will run the build correctly, I have yet to figure out what changes though and its rare enough to not be feasible.

Any help would be greatly appreciated!!!

Edit: something I believe I mentioned but will verify. Visual Studio 2019 or 2022 makes no difference.

Did you try verifying Unreal?

I’m nit sure how exactly I fixed it. But I think it was related to rolling unreal engine back to 5.0 from 5.1. After I did that everything worked.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms