Have to start Epic Games Launcher and Unreal Editor with -OpenGL flag. Any idea why?

ubp_s01_first_steps_in_unreal_engine_4

#1

This is not directly related to the course content, but I’m hoping that someone here may have an answer and know what is going on. The Epic Games Launcher and Unreal Editor both only work if I add the “-OpenGL” command line parameter.

The Epic Games Launcher was appearing invisible. The icon appears in the taskbar, and right-clicking where the window should appear shows the message “Please fill out this field”. It is the same as shown in this video (not mine): https://www.youtube.com/watch?v=_Di0UpVxRSA

I found that the launcher would run if I disabled my GTX 980M graphics card in the Windows Device Manager, or if I started the launcher with the -OpenGL option.

I also need to start the Unreal Editor with the -OpenGL option, which means that I had to find the location of UE4Editor.exe and create a shortcut directly to it. If I start the editor from the Epic Games Launcher or try to start it without the -OpenGL option, it immediately crashes.

Meanwhile, I have to open Unity (and games built with Unity) with the -force-d3d12 option to force it to use DirectX12. Without this, Unity gives me an all-white screen. That problem appeared to develop after installing the Epic Games Launcher for the first time.

I have stumbled onto workarounds that let me use both Unity and Unreal with different command line options, but I’d like to understand what’s going on here and fix whatever the problem is so I can just open both programs normally. Does anyone have any clues?

Update: The -OpenGL workaround no longer works. The only way to get either Unreal Editor or the Epic Games Launcher to open correctly is now to disable the GTX 980M in the Device Manager. If I don’t do this, the programs start but are invisible.

I’m running an Acer Predator 15 laptop (Predator G9-592) with Windows 10, Intel® Core™ i7-6700HQ CPU @ 2.60GHz (8 CPUs), DirectX 12, NVIDIA GeForce GTX 980M. The GeForce drivers are up to date.

Thanks for any hints as to what’s going on.

Daniel


#2

Hi Daniel,

Not the best answer I know but your best bet is to use the Unreal Answerhub or forum for this. This seems to be a very specific issue that myself or the GameDev TV team will be unable to help with directly.

Really hope you find a solution and if you do find one please do post here!

All the best,

Gavin.