Grass blade has strange outline when rendered. Please help?

Hi Michael,

Thanks for the great course.

I have run into a very strange issue with this section, that I need your help with please.

I have been trying to created a single blade of grass.

I draw a line with grease pencil, and converted it to a bezier curve, then added the geometry with a bevel. Everything looks good in the viewport shading, however when I render it I always see a think black outline on the item. This happens in both Eevee and cycles.

I am using blender v2.83.3

Do you have any idea of why this is happening, and what I can do to resolve it please?

I have turned off shadows to try to keep it simple. Any ideas would be great, as this is driving me crazy. I have tried adjusting so many parameters but to no avail.

Many Thanks,

Terry

That is odd. I have copied what I can see of your curve settings and it does nothing like that rendered effect.

Seeing you have a Mac my suspicion is becoming the AMD graphics card problems. They have some display problems, glitches. If you have updated your graphics card drivers it may even help going back as that was one mentioned fix for some glitches, though time may have fixed a later still update. If it is the AMD problem we need a more computer tech person!

What Blender version are you using?

1 Like

Thank you for checking. I have a 2013 MacBook Pro, so could be that. Probably time for an upgrade at some point anyway.

FYI, I am using blender version 2.83.3

The other strange thing is that while it is rendering the image looks fine.

It is only when it completes the rendering that the issue appear.

My son has a Windows laptop, so will give it a go on that. I think it is running the same version of Blender, so would be good to eliminate a hardware issue. I just assumed that it was just me doing something wrong as I am fairly new to this.

Thanks again.

Terry

1 Like

Great you have an option to try it on a pc, well windows laptop, probably without an AMD graphics system.

It is doubly odd for it to render correctly then mess it up on completion. Certainly some form of glitch rather than an error in what you have been doing I would think.

Looks a lot on a specific technique to create cartoon-like coloring.
Called: “Cell-shader”.

Do you use a specific (own made) material with nodes etc.?

1 Like

I have only apply a very basic material in order to colour it, but have since removed this and am seeing the same issue.

I have tried the same on a windows laptop (running Blender 2.9) and it looks fine, so I am thinking I may try upgrade Blender on my Mac. If that still does not work, then I guess the problem is with my device.

Thanks for all the advise.

Terry

2 Likes

Tick any post as solving this ‘ask’ please. Keeps things tidy.

Just discovered what the issue was. Ended up being me. Sorry!

Wanted to follow up on this post, just in case someone else has the same issue.

Problem was due to the fact that the grease pencil object was still being rendered. I had turn of the grease pencil object for ‘Viewport’ but not ‘Render’. Doh!

Thanks for the taking time to help though. Much appreciated!

Terry

2 Likes

Ah! well done finding it.

I never quite saw the point of using the grease pencil when you can just go straight to the curve. In fact I can’t think of any time I use it. Hence never crossed my mind it renders lol.

Yes that funnel hides very basic everyday needed buttons. They used once to show by default, no idea why they decided to hide them away.

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.