Graphical glitch

I tried opening the Godot Character Controller project in v4.2.1.stable.official and v4.2.2.stable.official, and in both versions, I got this weird graphical glitch that killed the frame rate and made it very difficult to see the scene around me. Any idea what could be causing this?

Hi Scott,

The Godot Character controller issues can be reported on the github page where it was downloaded from.
Unfortunately as its not part of a course i am unable to provide support for it mainly as i personally havent used it.
Maybe some of our students on discord have had a similar issue that can help

Hope you get this resolved i just didnt want to leave your post without a reply as that can be as frustrating as having an issue.

Thanks for replying. I actually don’t know of a github page for this project. I downloaded the project from the course downloads link, which points here:

There is also a Resources tab with another link to the same project:

I looked through the projects here and didn’t find the Godot Character Controller project:

Is there a github page for the Godot Character Controller project somewhere?


Hi Scott,

My apologies as i got confused with another post which was related to this package and godot actually crashing when opening it. A teaching assistant referred them to the godot github for godot crashes and i misread thinking there was a github for this package.

I’ve got access to the files and tested in Godot 4.2.1 using the below process.
Download the .zip file
Extract the .zip file
Open godot.
Import the project using the .project file

Everything seems to be working okay and no graphical glitches for me.

I would try redownloading the package and making a new project and see if it reoccurs.
If it does then it might be you need to redownload the godot engine and see if it reoccurs then.

Let me know how you get on and we can keep digging if these do not solve the issue.

Hi Marc,

I tried redownloading Godot 4.2.1 and the Godot Character Controller project and following your instructions. The behavior was similar this time but slightly different.

When I opened the project in the Godot editor, I got this weird looking glitch:

I tried rotating the perspective around, and it looks like that glitched section of the screen is some kind of copy of the view of the scene. It’s hard to recognize, but when I had shadowed objects pass in front of the screen (like the rock on the left and the tree on the right), I could recognize them in that glitched section of the screen.

Finally, when I tried to run the default scene, just about everything around me was white, and the frame rate was very slow. I was able to pause and access the pause menu. The only part of the environment that I could find that wasn’t totally white was the sky above me – here I’m looking up at what I assume is probably the sun.

Thanks for the response!

For there to be such drastic graphical issues on your end, and for Marc not to be able to reproduce them, it’s worth investigating whether there’s something going on with your specific machine to cause all this.

Maybe there’s some kind of silent Vulkan incompatibility. Try changing the renderer (top-right) from Forward+ to Compatibility. Note that this will cause lag spikes (potentially very long ones) the first time any given particle system runs, so do be patient with it if there are any of those around, as this is just a test. If the visual glitches improve, this guess would be on the right track.

1 Like

Good idea.

I opened the project again, and without changing anything, I already saw a difference. The whole scene was white in the editor:

I then switched the renderer from Forward+ to Compatibility like you said. The editor restarted, and then the scene looked ok:

I tried running the scene, and it looked ok:

The only bug I found is that the pause menu totally obscured the 3D scene:

I also tried the Debug Room scene, and that worked fine:

Is there anything we can do to find out why my machine is incompatible with the Forward+ renderer, and/or to improve the Forward+ renderer to be able to handle this type of case gracefully?


1 Like

That’s interesting - surely just a limitation of GLCompatibility. And this probably isn’t even very hard to fix if you compare it to the setup for that controls panel in the bottom-left. Looks like the graphics issues were indeed a Vulkan problem.

Well, that’s not something I have a lot of experience with, but basically what you’re looking for is to support Vulkan - that’s the technology behind the Forward+ renderer.

My best guess is that you might be running this on an integrated graphics card like the sort of thing found in a business laptop, but either way, you’ll want to find out what kind of graphics card you have, and then research Vulkan compatibility for that card. It might be as simple as updating drivers, maybe changing settings in something like NVidia’s dashboard, or possibly Vulkan isn’t supported at all on your hardware - no way to know ahead of time. The good thing is, at least we now have a good idea of what’s causing the problem. Good luck!

1 Like

I’m using a ~10 year old tower PC with an NVidia graphics card. I tried updating my NVidia driver and then reopening the project in Godot and switching to the Forward+ renderer. Things looked ok in the editor:

I tried running the game, and I got trippy graphical glitches similar to what I’ve gotten in the past:

I was able to find my way to the debug room, so I went in there to see how well it worked.

At first, things looked okay, although the frame rate was still very bad.

However, things quickly started glitching like this:

Afterward, I thought I’d capture the info about my NVidia graphics card and driver, in case that helps:
NVidia 1

Absolutely; this is exactly the information you need.

It looks like your driver is up-to-date and I was able to find GeForce GTX 750 on this list, which suggests that Vulkan should be supported:

However, based on the fact that you’re still experiencing issues with it, some other hearsay I found suggests that making it work properly, if even possible, would require quite a bit of tinkering, and that’s simply beyond what I can help with. Before I try to suggest something I have absolutely no knowledge of and wreck your computer, I think you will be best off sticking to the Compatibility renderer on this machine unfortunately (unless others have more suggestions of course). Sorry to disappoint.

OK, I will stick to the Compatibility renderer for now. If there’s any way for me to provide useful data that can help to improve the engine, let me know, and I will try to collect it and share it. Thanks for your help!

1 Like

At this stage @BH67 has got to the next stage i would have suggested testing (He’s awesome btw often beating me to the punch with solutions!).
It may just be that although the drivers are up to date that the graphics card is just too old to be compatible with some of the items used in the forward+ mode and the suggestion to use compatibility mode is what we would suggest for the older GPU cards.

For reference i did test on most of the machines i have at my disposal (Got 3 kids and 2 spare machines so i have 8 machines to test on), Unfortunately the lowest GPU is a 1050ti and none of those experienced this issue.

This being said my main computer i use was a replacement for a rig that decided to hard crash on a graphics issue and yesterday i found that it runs fine once i changed the drivers i was using as it was using the studio ready drivers over the game ready drivers.
This could be unrelated and i might discover it runs into the issue again (Had people playing need for speed unbound to try and crash it all day yesterday and no issues other than EA issues with textures on ultra).

I know you said you updated the drivers but it may be worth trying as a last ditch attempt to uninstall the graphics card and redownload the game ready drivers and reinstall and see if it works. If not then it may be that because the card is older that this could be the cause of the compatibility issue.

I am glad you do have something workable to continue working with it.

1 Like


I know I won’t be able to do that forever, but for now, I can, and if this helps get/keep people interested in Godot, I’ll do all in my power ^v^

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms