Github for Unity not showing changed files

I’ve asked this question on Udemy but decided to ask it here too.

I am using Unity 2019.1, and I downloaded the GitHub for unity.
On Sourcetree, there are uncommitted changes.
In Unity, there isn’t.
I did find system git multiple times, too, but no changes appeared.
I added this to an existing project
When making a new project it also didn’t work
I am using a mac

Very odd. It works perfectly on my windows 10 system. I had got and git lfs installed already.

Try saving the project and closing Unity if you have not already see if it works after restarting it.

@AARAV_IS_EPIC can you share a screenshot of your error i’m also using a mac and have not had any problems with git i have used it on old projects that i worked in a while ago that i never used git for and have been using it for all my new projects

Lloyd Risper

I have already reloaded the project. It didn’t work
It might be because I never installed git lfs



ok on the 2nd screen shot it looks like you have not setup your remote repo that could be why you are not seeing any changes look in the tab that says settings and see if you see an add remote repo if so add the link to your github repo

Hope this works for you.

Lloyd Risper

still not working

if you have facebook messenger we can do a video chat when i get some time tomorrow or since you have a mac we can screen share while screen sharing you can show me whats going on with your vcs and me on facebook and send me a msg and soon as i get finished taking care of things tomorrow i will help you

Lloyd Risper

Sorry can only share screenshots

ok np

Lloyd Risper

Which lecture inspired you to write this @AARAV_IS_EPIC? I want to link it to the video on the version of the course on our new platform.

Lecture 36 as it is showing the changes for you but not for me

There are some issues with the plugin either not reporting when the version of git is too low and/or it ‘finding’ the wrong one on the system to use (probably too low version again).


If you check the git version from a terminal window, and/or check the git version at the path in the Settings tab of the plugin, does it suggest the version might not be high enough?

thanks i am using 2.14.0 which is probably why it isn’t working