Getting weird behaviour with the Tank


#1

The tank’s barrel seems to go crazy at times, assuming it can’t decide which way to rotate? And the tank seems to be hitting bumps that don’t exist. Video to showcase the problems:
Edit: Ignore the white dot on the screen, I recorded this with the sequencer so that’s not where the tank is actually aiming.


#2

I’m not this far but that looks like a wild ride.

A small thing, but in watching this I also noticed there is no tread movement. I’m not sure if this is a thing but wanted to mention. :slight_smile:


#3

That’s not covered yet.


#4

We will get to sorting this, were just focusing in getting the tanks moving for now


#5

I have a feeling you’re referring to how to turret often chooses to go the long way round to get to a particular rotation. Though if you look at the video, you can see the barrel jitter all over the place; and when it starts jittering and I stop moving the mouse it will continue to do so.


#6

Quite right Dan, small screen and notification his your name so didn’t realise was your post.

So the jitter is strange. Have you made any headway into solving it? Does it happen if you check out our code?


#7

Didn’t notice I got a notification for this thread, but I downloaded your repo, exported my landscape to yours thinking it might have something to do with it, but seemed to be fine other than when looking downwards which I guess is what’s to be expected.

So I then went back to mine…and it fixed itself… I’ve had this problem for a while now too, originally thinking it was to do with how I had collision setup. I’ll keep an eye out for it in case it comes back though.