Getting a weird glitch when I try to apply animations to a model

Whenever I try to apply an animation to my model it expands to a huge scale and stretches out. I’m still a bit new to Unity so I don’t really understand what all is causing this to happen. Any help would be appreciated.

Wow, that’s quite the scaling issue…

Check the animation import dialogue. There will be several tabs Model | Rig | Animation | Materials
Under the Model tab, check the scale of the animation. There’s no great rhyme or reason here, but often animations scale is off… This one looks like it’s off by about 100x… you might try setting the scale to .01

Would I change the scale factor of the animation or the scale of the animation’s transform? When I change the scale factor it doesn’t seem to change anything.

I’m not entirely sure, as I’ve not had this specfic thing happen. (In fact, I just tried to duplicate it, and couldn’t). My thought was that it would be the Scale Factor. I have had a similar issue with less complex model imports like swords and such, and changing the Scale Factor generally did the trick.

If you’ve copied the animation outside of the fbx file like Nathan shows, check the animation for a transform: scale. If need be, scale values may need to be adjusted there.

I have solved the problem. When I remove the model and replace it everything works properly. Thank you for your help.

Excellent! I should have had you check the model too.
Of course, that big stick man walking through the scene stomping on players and enemies alike would make a good silly cinematic!

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms