General Unreal Issue?

Hello all,

I am still in the Bulls and Cow game, but, I am having a issue that I would like some guidance on. Unreal compiles the shaders every time the project is opened, every time! I added some assets from a pack and now have over 2k shaders to compile and its taking a long time and can’t really do anything while they are compiling.

I was hoping one of the lectures would talk about it after he encouraged us to make changes in the Bulls and Cows game but it never occurred.

Is there anything we can do to speed up/stop these compile times every time I load the project and or make a change that increases the shader count?

Thankyou and Regards.

That shouldn’t happen. It should only compile them the first time (note adding assets etc. may need to compile more shaders). Is it every time?

Yes, it happens everytime I load the project.

At first it was only around 700 shaders or so, it wasn’t too bad, made a couple of changes as per the lecture and it got up to 850, then I got my hands on an asset titled Australian outback and got carried away a little and now its almost 2.5k of shaders everytime I start the project. I went to Unreal Answerhub to see if there was a solution to the problem and found a couple of people asking the same question, but, I couldn’t follow their solution it was beyond noob level, so I posted my own question there specifying that I was a noob, unfortunately no response. So I also posted it here just in case someone could help. In this case I can delete the asset, but, moving forward could pose a problem as I will need assets eventually. In Unity I used to use a lot of assets a lot, some free others that were bought.

As always any help is greatly appreciated.

That’s a little strange, is that for all projects or one in particular?

Well this is the first project I have created in Unreal! I was following the course as closely as possible. The only other thing I have done is create about 3 console applications one as per the course - Triple X, and the two others being a console Isogram and hangman game that I have posted about previous.

I would have to start another proper Unreal project to see if it happens again - and seeing as this one wasn’t completely from scratch I might run into problems, knowing me I WILL run into problems :smiley:.

Bump.

Anyone have an idea of what going on or how to solve the problem of the shaders always compiling?

Did you experience the same problems with a completely new project?

Unfortunately … YES!

Just opened a new project using the FPS using BluePrint design then added in a Rural Australia assets, then imported a tree, it compiled the shaders after the import fully expected that, then I closed and re-opened the project and lo and behold, my friend the compiling of shaders commenced.

I have run out of avenues to stop it. I tried here and on 2 places on the Unreal forums and another the Ask forum. The only reply I got was “alternate path” and that was the entirety of the message, great.

Looks like I’m out of luck :unamused:

Is that the same asset (or in the same pack)? Is it an issue with engine/starter content?

Could you try verifying your engine if you haven’t done so already?

verify

In the stock FPS Shooter, I was using an asset from the store because the meshes do indeed look like scenes from the Australian outback, I was surprised how good the meshes were and the trees were moving like the wind was blowing through them amazing, blew me away :smiley:. This one tree has over 1000 shaders with it. Anyway, I deleted the tree from the scene and then deleted the Rural Australia assets pack completely and then just used the StarterContent pack and stated loading in assets left, right and centre and there were no shaders coming up at all (yay) - then I saved it, closed it down and, opened it up again and … Finished Asset Discovery … Compiling Shaders :expressionless:. I’ve closed the game down and opened it a number of times same thing occurs. Can’t figure out the problem with building the lighting hopefully that will be in a future lecture.

Just did it - seems fine!

So to be clear, that didn’t fix it?

Hahahaha - correct that didn’t fix it

Then I’ve kind of run out of ideas. @beegeedee, @Tuomo_Taivainen you guys have any?

@Vaughan_MacEgan Would you mind sharing the project so I can take a look. I’d be curious to see if it’s actually the project or something on your machine.

Don’t mind at all - but where, and, how would I sent it?

Take a copy, zip without binaries and share with GDrive or OneDrive or something?

Just checking, are you using revision control? If so, can you tell me if DerivedDataCache, Intermediate and Saved folders are committed? This can also apparently trigger a rebuild of the shaders. Also make sure your Binaries folder is excluded too

If by revision control you mean something along the likes of GitHub then no. The reason for not using such software is because the software wouldn’t work. One of the lecturers or assistants in the Unity course @Rob tried to help me get a repository up and running but with no luck. I tried about 3 or 4 variants and none worked. It’s like video editing software the only one that works is Windows Movie Maker and that’s it.

I think I have GoogleDrive, but, I haven’t used it in years, I’ll have to find it first then familiarize myself with it and then have a go at uploading the files, I’ll have to do the really small FPS game with Starter content the other is Bull and Cows is well over 2GB. It’s early in the AM now so I have to wait till tomorrow before doing anything.

Thanks for having a look at it.

1 Like

Quick question, where are you storing your projects on your computer? This almost seems like a weird file permission or “path too long” issue.

Also, while shaders are being compiled, are there any error messages in the output log?

Well, good question. When the Shaders kept on compiling and found out that is WAS a problem, I wasn’t sure at that point, I had all my files on the D Drive. I have a partition on the drive. Unreal at first wouldn’t load at all when I was running it from the D Drive so I deleted it and re-installed it on the C drive using all the default settings.

Then I set up the Unreal projects on the D Drive, like I said I didn’t know it was a problem at that time but when I found out it was - I created a new folder again on the C Drive and created the FPS shooter and used the starter Pack put out a stack of meshes and saved the project went back in, and there was the compiling of shaders when I started it up “everytime”. There were a lot less shaders this time only 300 or so, because its pretty basic stuff, but, when I incorporated that tree I keep talking about it was well over 1k. So it happens regardless of whichever drive I have the “project” stored on.

Actually I never looked at output log while the shaders were compiling. There are a lot of Yellow and Red Lines appearing like the following:

  • LogDerivedDataCache: Display: Failed to write TEXTURE_E01F4250BECD420DA9CE63B5EECEC2C2_OODLE_AutoDXT_11_6D2D972243FD5DA901A2__5728A548ACAC144C0DD81CA3F6A4481B1979E5B0 to HierarchicalDerivedDataBackend. Error: 0 (The operation completed successfully.)

  • LogStreaming: Warning: Failed to read file ‘…/…/…/Engine/Content/Editor/Slate/Niagara/Common/FlatButton.png’ error.

  • LogDerivedDataCache: C:/Users/Vaughan/AppData/Local/UnrealEngine/Common/DerivedDataCache: Move collision, attempt at redundant update, OK C:/Users/Vaughan/AppData/Local/UnrealEngine/Common/DerivedDataCache/1/5/2/STATICMESH_9CE2B6FB46754B699726C4AA1515F12E_228332BAE0224DD294E232B87D83948FQU__3BDCAB4C2FB5408A649222AFA534588EF1DF2F41.udd.

Got me bamboozled. And don’t forget the swarm will not kick off for a lighting build for whatever reason even with the Antivirus and Windows Defender being turned off!