GameMode Blueprint Not Updating

Hello Everyone,
Something weird has happened to my GameMode and I cannot figure out why. The GameMode that my project is using does not seem to update when I make changes in c++. For example, when I tried to add a log in the BeginPlay() function to help debugging another problem I was having and I compiled my code many times, the log was not showing up. Another example was when I removed a line of code that would have left the class using an unitialized variable, but the code still compiled many times and it worked the same as before. I tried making a new GameMode Blueprint derived from the TankGameModeBase C++ class and I was still having the same issues. I also checked to make sure that my current BP_TankGameModeBase was using the TankGameModeBase C++ parent class and it was. I am not sure what screenshots I should include because I just cannot figure out where the problem is coming from. Thanks!

Are you sure you set that to be your game mode in the maps and modes of your project?
Perhaps you have a world override (in world settings)?

Yes, I have the correct GameMode in Maps and Modes. When I pressed the browse in content browser it took me to the correct blueprint. I also have the default world settings.

Hello again,
Just today I got a new computer because the old computer that I was doing this course on was terrible. When I tried it on my new computer it worked immediately. I am not sure what was wrong but it is solved now. Thanks for the help and sorry for the trouble.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.