FVector:: intellisense not working in visual studio code

Hi. It autopopulates with the wrong options.

It’s saying FVector comes from MathFwd.h

But I’m not certain that’s correct. For example,
TVector uses Vector.h. Can anyone confirm, or possibly have a fix?

Do you have the workspace open? Could you show your full VS Code window?

I have same problem and still not solve problem
I add my vscode window capture

and add c_cpp_properties.json in case you need it.

What can I do?

Do you have the workspace open? Do you get any autocomplete?

I think red circle means Workspace is open.

And my vscode autocompletes like SetActorLocation or FVector. but, it doesn’t work FVector::Dist.

I have same problem like first questioner.

If this is not your intention, please explain in more detail. Thank you

It’s probably not finding the static member functions specifically. Could you see what you get via .?

FVector Test;
Test. // what do you get after `.` here?

I solved my problem. but, I don’t know which one is the solution.

I guess the red circle button solved it.


Thank you!

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.

Privacy & Terms