Fun With Physics Lesson - Passive rigid body allows objects to pass through it?

Sorry for asking for help, but I’m struggling to get physics to work properly, because even when I set the plane as a passive rigid body, the bowling ball simply falls through it. Even changing the settings in rigid body properties doesn’t work.

I know that asking without showing a video or image is not ideal, but it happens so fast, that the ball appears to simply disappears of the scene.

Sorry if I didn’t explain properly.

1 Like

Try lifting the ball a fraction above the plane, just in case it is starting already considering itself to be past it.


There needs to be a space (margin) between an active (ball) AND passive (floor) object.

1 Like

Thank you for your responses, but unfortunately, it didn’t work. As soon it changes to frame 2, the ball disappears (it’s probably better to say that the ball already fell quite a distance), even if theres a margin between the ball and the floor.

1 Like

Please show us some full screenshots with the relevant panels open and one of us may see something set up wrongly.

Blender has a screenshot capability.
Along the top left menu bar, Window; Save Screenshot.
That will make providing images easier.


In the dope sheet you can see if you have keyed frames of objects position, location and rotation.


  • the origin of your objects
  • the object scale (need to be 1) - apply scale

Hopefully these screenshots can help.

1 Like

Can not find out your problem.
lower the floor!!!
as a test run


There is an accompanying resource file in that lesson BowlingAnimated.blend

I suggest you download it and make direct comparisons with the relevant settings. Something would seem to be out that is hard for us to spot. It may be related to the animation and physics interaction. Get the physics working before any animating. As is done in the lecture. Another route may be to remove all the animation, well a couple of keyframes are all that show. Until the physics works.


Thank you to both of you trying to help me. I tried out your suggestion, but, to no avail. I tried to lower the floor and to see if there are any diferences between my file and the resource file, but it didn’t work.

Fortunately, I managed to get the physics to work by creating a new blend file with a new floor and appending the bowling ball and pin from the original one. Here’s the final result:

The main difference between the original file and this new file was that the original file had a plane with a bevel on it and in the new one was just a regular floor.

Original file:

New file:

I don’t know if it was that what caused this issue, but, thankfully I managed to get it work.

Thank you again to both of you for helping me. :+1:


This, use new .blend file trick does help sometimes.
You probably switched on/off Blender settings. Or strange combinations which make blender behavior different. It happened to all of us. Especially in the beginning learning Blender. Then you unaware of your actions or don’t see the implication further on the road.

Glad you’ve managed it on your own. It grows your confidence, but the learning process is also a little bit frustrating.
Try to have fun! That is the most important part.


Glad you got it sorted. As FedPete says that ‘start in a new file’ does work frequently, though I always try first to find out what is wrong in case I repeat it!

I do not think the bevel made any difference.

End result is great! :star:

1 Like

It may possible. Unfortunately, I still couldn’t find out what caused the issue, but, at least it’s working now.

There’s always a element of frustration when learning for the first time. It’s a part of the process and I already expected that I would encounter something like this during the course.

Yes, I’m still having fun! Even though it was a bit frustrating, it did bring a smile to my face seeing an animation that I made for the first time.

Thank you! :grinning:

I tend also to try to find out what is wrong, so I can learn from it and avoid it in the future. But I spent quite some time yesterday trying to find what caused the issue, but, in the end, I could’t do it and I tried something else. I had my suspicion that bevel could cause the issue, but it might not be it. I will try it again and see if there’s any difference


I suspect here that the physics cache wasn’t rebaking after making changes to the scene. Deleting the cache in the physics properties tab and forcing blender to rebake the physics simulation data can sometimes help.


Thank you for your comment. I tried to delete the cache, but, unfortunately, it didn’t work. Now the ball simply stops on the last frame, but, at least it doesn’t “sink” through the plane like it did before. I will try again the whole challenge to see if I can make it work.

Thank you again for your comment and for your help.

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms