Frustrated at Parents connection being lost

Ive followed along at all times, by parents to bones was lost at some point when trying to keep everything connected.

I am not sure how to go back, I tried redoing the parents on the lamp, but constantly lost mirror etc, loss bones and trying to reconnect them from scratch didnt work either… frustrated beyond belief… not sure where to go beyond trashing it all… my last fresh save was pretty far back.

1 Like

Perhaps if you include some full screenshots we can help or see what is going wrong.

Some things look different just by the mode you are in.

1 Like

Note sure what I can show, that maybe my problem I cant really see what the issue is:

overall image:

I can move my lamp as a whole:

I can move the entire objects if I select my base bone:

I can pose the bones, nothing is reflected in the lamp

It all started when I had to parent keep transform. I lost the empty in the lamp base… that caused my base to rotate without the arm (and mirror).

I had to reparent the empty (and low arm) to the bottom arm base and things went to heck from there, I noticed I didnt apply my modifiers… was there something else I mighta missed?


ultimately the parenting stages I guess is my issue

1 Like

Well the first thing I noticed is the Z rotation on the object, Lamp Base in image 2.

Apply rotations and scales!
Otherwise all modifiers are using data from the original position not the rotated or scaled ones.

That alone may not be the entire problem but on step at a time.

1 Like

I see that, thank you, after I applied my parent, my empty wasn’t located and had to move things as a result…forgot to apply those changes

1 Like

I guess a better question would be how in the lamp and armature would I go about redoing the parenting process to ensure all objects control each other like I should.

What I have tried:

  • Reset all parents

  • Bulb down the base, clicking in sequence (bulb-shade-ball-upper arm-lower arm-mirror empty-arm base-lamp stem- lamp base)

  • Ctrp-+p to parent them all.

  • lamp all moves together

  • Armature

  • click each lamp item and parent to the bone (Ctrp + P to bone)

  • Here none of the bones interact with each other… each bone only controls the lamp piece but not lower bones do not control its child)

  • once each bone is assigned, parent all bones down to the bone base (keep transform)

Its basically the steps I remember from the course… so if there was something off there, that might be the issue.

thanks in advance

1 Like

Don’t forget pose and edit mode.
In edit mode build the shape of the armature exactly as the lamp mesh is!
Then connect one by one the mesh object to the bone. Check every time its correctness (rotation).
And really don’t forget to check the scale ( needs to be 1) and the origin of each mesh object.

If you change something in between it affects the armature behavior.

We all are eager in this armature challenge to see something moving, but then we forget to check all those things (working too fast). Leading to strange animation behaviors. We all have experienced these annoying problems. Keep calm, think about what you have learned. Not just button clicks showed by Michael.


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms