Forwardspeed does not exist

Hi guys! So I have tried to follow the video and I still managed to get an error somehow… I tried copying the same mover script, my player has the mover script on it and the animator component with the attached controller… but it still says that the Parameter ‘fowardSpeed’ does not exist… and the different animations do not show…

1 Like

The error is correct. You have a forwardSpeed layer, not a forwardSpeed parameter.


Delete this one, switch to Parameters and create it again


As stated by bixarrio, you made the mistake of setting the forwardSpeed as a layer and instead of a parameter.

The Parameters tab is, basically, the tab that holds the values you use in the Animator such as booleans (bools), floats, integer (int), etc. and they direct the blends and paths of the layers.

The Layers tab holds the layers which, each, hold an instance of the blended animation states and can be used with an Avatar mask and weight-adjusted. (For example, you can have 1 layer for general movements and 1 additive or replacing layer with an Avatar Mask to only target the upper body so that the upper body animation is based on something like the character current equipment or you can also have 2 identical layers in layout, but with different animations such as monster animations or female/male variants of the animation then setting the layer’s weight based on what you want the animation to look like.)

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms