Fix for blurry/discolored assets

If you made your own assets like me you may have found that they look blurry and weirdly discolored when imported into Unity.

Rick doesn’t cover it in this lecture, but there’s an easy fix, you just need to adjust 2 settings in the sprite inspector.
First, set the Filter Mode to “Point (no filter)”.
If you’re familiar with Photoshop, this is basically the same as “Nearest neighbor”. It doesn’t try to “pretty up” your picture by making it all smooth, preserving the pixel art style.

However, you may find that your image is still weirdly discolored, or has artifacts, like this:
This is a compression issue.

To fix this, head a little bit further down to the “Default” tab, find the “compression” setting and change it to “None”.

Don’t forget to hit “Apply”, and your pixel art assets should look crisp, clean and color-accurate.

Hope this was helpful.


Thank you for this! I was going to make a post about this same thing when I realized independently that the default filter and compression options needed to be changed to make things look right, so I’m glad to see that somebody already made a post about this very thing.

1 Like

Privacy & Terms