Fatal Error LNK1104 cannot open file kernel32.lib

Hey guys I’m working on the TripleX game but i keep getting this error I’ve tried reinstalling windows sdk but that doesn’t help does anyone know of a possible fix

Did you install Visual Studio with these settings?

Yes, unfortunately that doesn’t seem to be the problem.

Could you try repairing your Visual Studio installation? You can do that via the Visual Studio Installer.

I have tried that now but it’s still the same

If you go into the Individual Components tab do you have a Windows 10 SDK and the Universal C Runtime Library installed?


Are you able to create, compile, and run a Visual Studio C++ project?

I haven’t tried to do anything past this error because it happens every time I type in CL triplex.cpp so I assumed it wouldn’t be able to compile and run

Nevermind I tried and it doesn’t work

To be clear, using Visual Studio Community 2019 and not VS Code?

No, I was using VS code

Could you please try creating a Visual Studio Community project using the C++ Console Application template and see if you’re able to compile and run the project?

Sorry for the late reply but I’ve reinstalled windows and that seems to have fixed thanks for the assistance though.

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms