Failed to compile newly created module

I have a problem with compiling with visual studio code in unreal engine (5.0.3).

When I cteated New C++ class in UE,I got this message [Successfully added class ‘MovingPlatform’,however you must recompile the ‘ObstaleAssault’ module before it will appear in the content Browser.Failed to compile newly created game module.]

This is output log file link

Please help !:pray:

What version of Xcode and macOS do you have installed?

This is screenshot.Please help🙏

Pretty sure UE 5.0 doesn’t support Xcode 14.

Try downgrade Xcode or get Unreal 5.1

1 Like

Also I searched this topic in google.But, for some reason, I got no answer.Why is that?:pray: Please

You mean that If I change UE5.1.1,the problem should be solved.

Depending on what you searched there could be limitless reasons for the underlying cause of the same issue.

Also yes, Xcode 14 isn’t supported by UE5.0

1 Like


1 Like

And when i open my project, It stopped 35% and not moving forward.What can i do for this?:pray:

Wait. Compiling shaders for the first time is not a quick process.

1 Like

Thank you​:pray: :heart:

I solved the problem.Thank you so much​:heart_eyes::relaxed:

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms