Error with my blueprints

My blueprints seem to not be functioning after i closed my editor yesterday, when i tried to open my project, it told me that there were files missing in my editor, so I would try to restore them and open the project, but all of my blueprints (the likes of which are derived from a C++ class named basepawn, were missing, when i tried to open the blueprint i got this error message here

i attempted to open it regardless, and nothing seemed to be wrong with the blueprint itself, as seen here.

i would proceed to use live compiling to try and fix the issue, but this didn’t work, so i closed the editor and compiled in visual studio code, in which this also would not fix anything when i entered the editor again.

I would check where the BasePawn C++ class was, in which i would find it, doing just fine, where i made it last.

does anyone know what could be causing this error and how i could fix it?

Did you by any chance rename the C++ base class after creating the blueprint? If you do that you need to use something called “redirectors” to add a pointer from the old name to the new one. Since the blueprint opens, you should also be able to re-select the class from the “Class Settings” button near the top in the blueprint editor, and then you can change the “Parent Class” in the details panel there.

attempting to do so does not allow me to select my class, and no, i didn’t rename the C++ base class before doing this.

Hmm, you might also want to try closing everything, clearing out the Binaries and Intermediate folders (I use VS so it might be slightly different for VS Code), and then refresh the visual studio code project files by right clicking on the uproject file going to “Show more options” and then “Generate Project Files”. Then try to recompile everything again from VS Code and relaunch the editor.

It’s also possible the blueprint got corrupted but I’ve found that this is rare in practice and is usually instead the result of something being out of date on the C++ code side.

Attempting to recompile with visual studio code now says Targets cannot be built in the Debug configuration with this engine distribution"

You may need to select “DebugGame” or the “DebugGameEditor” configuration in VS Code. The first is for launching the game by itself (without the editor and closer to what a packaged build for players would look like), and the second one is for launching in the editor, which is probably what you need.

“Debug” by itself is if you were building the engine from source and debugging it as well as your game.

Found this possibly related post: Targets cannot be built in the Debug configuration with this engine distribution - Unreal Courses / Ask -

Build configuration documentation: Build Configurations Reference for Unreal Engine | Unreal Engine 5.3 Documentation

So i can not compile it using DebugGame, and the option for “DebugGameEditor” is not present.

What is the output of using the build task

ToonTanksEditor Development Build?

i tried using this just now, no dice.

just to be clear, i am using the correct configuration, right?

i have come to the clonclusion that there is something inharently wrong with my C++ Class (basepawn), i have deleted both my tower and tank blueprint, and tried to make new blueprints with it as the parent class, however none of my UPROPERTY’s are actually present when i make this

What you have on the left is to launch a separate instance and attach a debugger; it’s separate from running a build task.

And I can’t see the output of the task on the right to be able to tell you if you did.

should i take another screenshot?


If you’re launching the project from either double clicking the .uproject or from the Epic Games launcher then that is the wrong task; that opens the development build of the project so would need ToonTanksEditor Development.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.

Privacy & Terms