Error when compiling UPROPERTY


I ran into an error while trying to complete the course on UPROPERTY Variables,
I wasn’t able to compile it in Unreal either without a return error.
I checked the discussion here and didn’t find much that matched my issue. After a google search the best I could come up with would be maybe a missing extension for visual studio~ so I downloaded a few extra based on a forum post,

Still not able to compile it, would appreciate any help

I’m not using VS Code myself, but if you’re having trouble compiling with VS Code you might want to take a look at this page: Configure VS Code for Microsoft C++.

Also make sure that you clean your project after making any toolchain changes before attempting to rebuild.

Hello, hopefully this helps Unhandled exception when building blank project: Version ("1.2") is not supported version - Programming & Scripting - Unreal Engine Forums

@El1mination That’s the post he was referring to in his second screenshot. :laughing:

Also, I would avoid using the 14.31 toolchain per this bulletin from Epic:

After some more tinkering I was able to clean the build (Via Run Build Task), followed up with running the build again, This time no errors. But anytime I try to compile it now in Unreal, I’m getting a similar error

Several people have been having trouble using Live Coding along with VS Code. I’d stick to just building from VS Code if you are able to, or you can try installing VS 2019 or VS 2022 CE. I’ve been following along with the course using VS 2019 and LC has worked fine for me.

So as I was coming back to this issue today, I was intending to just start a few steps back, and this time with VS 2019, so I reinstalled it over the 2022 CE, Upon boot up~ Unreal now seems to be able to compile everything. So While I have no idea (I really wish I did) what happened, I THINK it has to do with the edition I was using since its all good now.

Also thanks for your help, really appreciate it!

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.