Error when atttempting to compile in UE4 on Windows

In this section after going to start up the new project it goes to complie and then gives this error:

An error occurred while trying to generate project files.

Running C:/Program Files/Epic Games/UE_4.15/Engine/Binaries/DotNET/UnrealBuildTool.exe -projectfiles -project=“C:/Users/sahba_000/Documents/Unreal Projects/UnrealCourse/Section_01/Section_01.uproject” -game -rocket -progress
Discovering modules, targets and source code for project…
ERROR: No 32-bit compiler toolchain found in C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\bin\cl.exe

When doing the setup for Visual Studio I included the Unreal Engine installer and the Win 8.1 SDK as instructed:

Thanks for any help

Edit: FWIW I found that I had an old install of Visual Studio still installed, for VS2015. When I ran it it did an update and then I retried. Sure enough it worked as shown in the video’s. The only slight difference to the video is when UE went to open the project I was given a choice of which application to use to open it. VS2017 was one of the choices, and it worked fine at that point.

I hope posting this is helpful to someone else as well.

Are you running on a 32-bit machine, because Unreal requires 64 bit

No, it is x64, Windows 10. The fix I noted in my edit seems to continue to work.

Privacy & Terms