Error "cant add script behavior assembly.cs

Cant figure out why script isnt being added to object I followed the videos exactly and i also tried just using a completely new script without changing name and its the same error.


Hi Austin,

Welcome to our community! :slight_smile:

Is Visual Studio selected as your External Script Editor in Unity (Edit > Preferences > External Tools)?
Are the Unity development tools installed in VS (Tools > Extensions and Updates)? If they are not installed, go to Tools > Get Tools and Features.

yeah I’ve done both.

You haven’t written any code in the script yet, have you? If you haven’t, try to delete the script and recreate it.

I’ve also tried that as well as starting on a new project? The only thing that I think is left to do odd to reinstall unit completely

How are you getting on with this, @Austin_Tran? Did reinstalling Unity help?

Reinstalling fixed the issue Completely.

Awesome! :slight_smile:

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms