Error C1853 - ... precompiled header file is from a previous version of the compiler, or the precompiled header is C++ and you are using it from C (or vice versa)

tl;dr: For some reason some dll file was broken. Deleted all the same folders as Ben indicated in the previous lecture about the gitignore, rebuilt from the launch of the project, failed a few times and then went through and was ok.

I get the same error both in VS 2017 and in Unreal 4.19.2. The version hasn’t changed since I generated the file (same day).

But its telling me the version is a mismatch, or that the header is " C++ and you are using it from C (or vice versa)".

I tried relaunching the project and kept getting a message that UE4Editor-EscapeTheRoom.dll was built with a different engine version. Why I accepted the rebuild it would fail to rebuild.

After a bit of trial and error, I finally deleted the folders Ben indicated to ignore in the gitignore. At first try this failed to launch and rebuild. I rebuilt again and it went through. I also tested out the compiling in unreal again and now it works.

Had to regenerate the VS project files twice as well. But in the end the build succeeded in VS as well.

No all is well.


I had the same issue, and following your advice, I deleted just the Intermediate folder, and then everything compiled correctly.



Seems like this has not worked for me. I have deleted the indicated folders, generated the VS project and then built the project and still no luck

Privacy & Terms