Error after completing Cursor Lectures [HELP]

After completing the cursor lectures, my game produces an error when I change scenes. I tried Sam’s version and get the same error. It’s a NullReferenceException dealing with the PlayerController.InteractWithUI. Everything works fine if you don’t try and go into another scene but if you do, you need to delete the Save.sav file to get things working again.

Will there be an update or fix for this lecture?

A NullReferenceExeception happens when there’s a reference to an object in script that doesn’t exist or cannot otherwise be found at runtime. Have you tried comparing your code to the repository on GitHub? Also, it might help if you share some screenshots, both of your script and perhaps the inspector tab of the object in question. It’s unlikely the problem is within the lecture itself as such an error would have been found in the recording process.

Edit: Also, if you double click on the error message, it will take you to the offending line in code, so getting that would be super helpful in ironing this out.

This topic was automatically closed after 5 days. New replies are no longer allowed.