Enemy not animating in game play mode


I’ve just animated my enemy placeholder as shown on lesson 71, made sure that there’s an animation track on my master timeline, there’s an animator component (created automatically when I created my anim track) on the enemy, and there’s key frames on the animation on the points I moved the sphere.

Everything plays ok on scene view and game view - I can drag the bar or press ‘play’ on the timeline window and both the player and the enemy move.

But when I press the main ‘play’ button on the top of the screen, only the player moves. The sphere remains on its initial place.

Can someone help me? I’m pretty sure everyhting is alright with the animation track for the enemy, but I may have missed something in the process.

Thank you!


What you described sounds correct but since the enemy does not move, there must be something wrong, maybe just a little detail. Are there any error messages in your console when the enemy is supposed to be moved/animated during runtime? Does the enemy game object have got any script components attached which manipulate its Transform component as well?

Hi Nina,

I’ve just deleted everything and restarted from scratch, and it worked. Pretty sure everything is the same, but now it worked. Thanks for the reply!


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms