'EGuessStatus Status = EGuessStatus::Invalid_Status;' - Is it necessary?



I tried only
‘EGuessStatus Status;’
and it worked.

Is there a reason for putting
after ‘EGuessStatus Status’?


I think Ben does that so the value of Status is known at all times. I’m not sure what the value of Status might be if is not defined explicitly. I could be wrong though