Did setup of SourceTree repo in diff order - Windows 10


  1. I set new SourceTree repository up first
  2. Went back and did the Unreal & VS parts of this lecture
  3. Jumped forward to point in lecture where he starts dealing with the .gitignore file in notepad and SourceTree

Long version:
I was unable to follow Ben’s directions in this video for setting up a git repository thru SourceTree. With a folder of Unreal and VS files already created, SourceTree was telling me that I had to select a new, empty folder.

So I deleted the VS and Unreal files that Ben had us create from the beginning of this lecture, and instead setup a folder inside SourceTree named “03_BuildingEscape”. SourceTree liked this, so I then went back and followed Ben’s directions at the beginning, which was setting up new Unreal project, deleting files, etc., and so now it seems I am back in sync, as of the end of this lecture video.

Just putting this down for posterity, and for any other lost souls.



Yeah same issue. Tried your fix but still getting the same error message even though the folder is empty.

Had to delete the folder even though it was empty and then leave it in the create directory field so that Sourcetree was happy and created it itself. Annoying but seems ok now.

Privacy & Terms