Default Pawn Set to Tank, Game Mode set to Tank, No Tank?

Tank_BP is type pawn, Default game mode is set to Game_Mode_BP, Game_Mode_BP’s default pawn is set to Tank_BP. No matter what I do, the tank does not spawn.

The only way i can get the tank to spawn is to tell it to auto possess the player.

This should stump any1 reading this as much as me… I’ve never had a problem with this before.

It was a bug. After i set the tank to auto-possess the player, I tried disabling auto possess. After saving the project, I tried hitting play and spawned as the tank.

I’m not positive if i tried saving the project earlier, but I had the same exact config as before I posted here. The only difference was I set tank to auto possess. When auto posses was disabled again, it magically worked. Holy fk*ing bug.

The only thing i can imagine that i just thought of is that maybe by setting the tank blueprint to auto-possess, it automatically enabled some setting that i could not find no matter how long i skimmed thru Tank_BP. But there should not be any additional settings needed, so this doesn’t make sense. It had to of been a bug…

One other long shot suspicion would be that I ignored Ben’s warnings of the socket rename bug, assuming that by 4.15 it was fixed, and it was, seemingly… As otherwise the Pawn blueprint using these sockets did not spawn in the world until the auto possess and auto possess disable attempt that I did.

Forcing the engine to spawn the tank into the world could have also made it somehow recognize it and unglitch something; which is my initial suspicion as finding it working after doing this.

Thanks - this helped me too!

1 Like

I had the exact same problem, and i found that the solution that worked for me was that the play button has a drop down list and the mode selected was “simulate”, when i tried play in viewport it spawned a tank immediately.


Tanks a lot!

1 Like

Privacy & Terms