Death Collision Fix

This should have been added long ago. Don’t know if he ever bothers to fix it; there are obviously many ways to deal with such things, but if you havn’t noticed the pawn’s collision interferes with gameplay after death.

When we added our death function we could have quite easily also added this:


^Removes leftover collision and adds un-spawn delay.

Beware there is a bug dealing with the Set Collision Enabled node here. For some reason it either replaces the default when using the node, or for some reason if your blueprint contains the node, some sort of bug causes the capsule to loose its collision on begin play.
After playing with it i believe the work around is to place the set collision enabled node first, then drag in your capsule component reference after, and connect the pin. The other thing that might have unbugged it was when I placed it on the end of the chain after delay and delete actor. Placing a delay node before the set collision enabled node also can fix this bug.

Another Fix option could be to resize the capsule component on death to be more fitting for a dead body on the ground. (or even rotate and move the capsule in fitting the death direction)

This also has a great side-effect of making the AI stop shooting you and walking away after you die. Taking his vengeance out on you then leaving.

Privacy & Terms