CubeDude Armature Modifier cannot be applied

17_cd_bcc

#1

Hey Guys,

I am stuck in the Blender Character Creator: Rigging Humanoid 3D Character
At lesson 66. Vertex Groups

Minimum Steps To Reproduce

  1. Take the blenderfile and try to apply an armature Modifier
    4_CubeDudeTry2_CustomVertexGroup_bugfix.blend (580.6 KB)

All Vertex Groups are allready defined and named correctly.

What Was Expected

At the Course Step 66. Vertex Groups, you have to apply an Armature Modifier
which is taking the Vertex Groups and assignes them to the correctly named
Rig Parts.
While having the Modifier set, but not applied, the armature works perfectly
in Pose Mode

What Happened

After clicking on Apply at the Armature Modifier, nothing happens.
The modifier vanishes and is not longer existend.
There is no function anymore.
When setting up the Modifier it works until I apply again.

Before clicking on apply:

What I’ve Tried

I took older versions of CubeDude, but it was the same issue.


#2

Is there a reason that in the lecture it is not shown, that the Modifier is applied? Maybe we dont need to, but he did not mention it.

I can reproduce my problem much easier now:

  1. Create a Cube
  2. Create 3 Bones. Name them Top, Bottom and Side.
  3. Take the top face of Cube and create Vertexgroup “Top”
  4. Take the bottom and create the VGroup “Bottom”
  5. Take a side of Cube and create the VGroup “Side”
  6. Get to Object Mode and create a Armature Modifier and select “Armature”.
  7. In Pose Mode the rig works.
  8. Try to apply the Modifier - and the Modifier vanishes.

Can Somebody explain what gone wrong?
Thank you so much


automatically bumped #3

#4

Hi Sebastian,

I think the issue here is that in the video mikey unparents cube dude from the armature and this clears the original armature modifier on cube dude.
Later Mikey adds the armature modifier back to cube dude but actually says “Apply the armature” but thats not what he does.

Technically he should have said Add the armature as at the end of the lecture cube dude still has one on him.


#5

Hi and thank you very much for your time.
I have tried to understand your comment, but in fact i am still unsure.

If i parent the CubeDude to my armature, so that the armature is the parent, it is not using
the vertex groups.
And if I do not parent these, and just use the Armature Modifier, it is working fine.
It is taking my Vertex Groups correctly.
Why is nobody in any tutorial really applying the Armature Modifier?
Because when I just export the Blender File, Unity does not know what to do with my rig.

I am very frustated to be the only one, not getting this working =)
Maybe its the language barrier, but could you explain the steps i have to do more detailed
and step by step?

That would be awesome =)
Thank you irresistiblejelly.


automatically bumped #6

#7

Maybe i understand it now. I downloaded the cubedude blendfiles from the lecture and there is the parenting of rig and the object and also the Armature Modifier in it. But the Modifier ist mit applied! And it will never before applyied, it seems its just for checking if all moving correctly.

Is this right?


#8

Yep thats it, Its getting the movement from the armature via the modifier so applying it at this point means its gone


#9

Aaah thank you!!! I am so glad you helped me, now I can proceed :blush:


closed #10

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.